My random crashes have been solved.

SouthernGorillaSouthernGorilla United States Join Date: 2017-07-26 Member: 232057Members Posts: 156 Advanced user
I started this thread just to simplify things. The thread on my crashes has gotten so huge it's unlikely anybody is going to scan through it in hopes of finding an answer. So I'm putting the final solution here to make it easier for others (including the devs) to find it.

After replacing the PSU, CPU, mobo, and RAM all with no luck and doing a clean reinstall of Windows as well as Steam and the game... still with no luck-- it seems the problem was in the BIOS. And it was an easy tweak. I went in and disabled every single "power saving" feature (Suspend To RAM, etc.) I could find. Then I enabled the HPET (High Precision Event Timer) both in the BIOS and in Windows. We've gone from being unable to play more than 30 minutes or so at a time to being able to play uninterrupted for hours. We even left the game paused and went out for a couple hours with no problem. Yesterday my wife spent literally half the day playing another game (Civ V) with no issues.

I'm not sure why either of those tweaks would stop crashes, but it may be something worth adding to whatever diagnostic recommendations are generally given to people reporting crashes.
baronvonsatan

Comments

Sign In or Register to comment.