Newbie Hlds/ns Linux Server Guide

124»

Comments

  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    edited December 2003
    What do you type in the command line to execute the server? What does your server.cfg look like? Are you using an autoexec.cfg file or no? Are you running the server behind a router? Does the Linux box have a static public address or a private one being port forwarded? Let me know.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • instantinstant Join Date: 2003-06-19 Member: 17500Members Posts: 27
    Got it all working, thanks mate, great guide. The DNS was borked, so then it couldn't resolve WON host and auth. smile.gif
  • The_TruthThe_Truth Join Date: 2004-01-17 Member: 25410Members Posts: 5
    how do i add rconmod and sv sheats (can u also tell me wut RPM's to download im confused on that bit). how do i add reserved slots and how do i give peep admin.
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    You need to slow down, all of those things are different and require different levels of services.

    First, did you read my guides? Most of it is pretty clear if you read it carefully. I even have a guide there for adding AdminMod to the server.

    sv_cheats can be enabled at the console or by setting an rcon_password in the server.cfg file.

    Reserved slots are controlled by an external metamod program such as AdminMod, AMXmod or clanmod.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • vermifaxvermifax Join Date: 2004-03-02 Member: 27075Members, Constellation Posts: 22
    Following your guide trying to start up a server on a redhat 7.2 server.

    I get to the point where I try and start up the server and get the following

    QUOTE
    bash-2.05$ ./hlds_run -game nsp +exec server.cfg +maxplayers 12 +map co_core -debug
    Auto detecting CPU
    Using default binary.
    Enabling debug mode
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/hls/hlds_1/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 16:53:50 Mar  2 2004 (2686)
    STEAM Auth Server
    couldn't exec language.cfg
    Server IP address 66.34.248.64:27015
    scandir failed:/home/hls/hlds_1/./platform/SAVE

    ./hlds_run: line 57: 12189 Segmentation fault      (core dumped) $HL_CMD

    warning: Unable to set global thread event mask: generic error
    Error while reading shared library symbols:
    Cannot enable thread event reporting for Thread 1024 (LWP 12189): generic error
    Error accessing memory address 0xbffff6e0: No such process.
    339    vfscanf.c: No such file or directory.
    Error accessing memory address 0xbffff6e0: No such process.
    debug.cmds:1: Error in sourced command file:
    Error accessing memory address 0xbffff6d8: No such process.
    email debug.log to linux[email protected]
    Thu Mar  4 01:01:29 CST 2004: Server restart in 10 seconds


    and in debug.log
    QUOTE


    CRASH: Thu Mar  4 01:01:27 CST 2004
    Start Line: ./hlds_i686 -game nsp +exec server.cfg +maxplayers 12 +map co_core -
    debug -pidfile hlds.12184.pid
    Core was generated by `./hlds_i686 -game nsp +exec server.cfg +maxplayers 12 +ma
    p co_core -debug -pidf'.
    Program terminated with signal 11, Segmentation fault.
    [New Thread 1024 (LWP 12189)]
    #0  0x400b9b4d in _IO_vfscanf (s=) at vfscanf.c:339
            in vfscanf.c
    #0  0x400b9b4d in _IO_vfscanf (s=) at vfscanf.c:339
    End of crash report


    I can start up a simple half life server using -game valve +map undertow with no problems, however can't seem to get vanilla no mods NS running. I've checked the permissions, all the files in /home/hls/hlds_1 on down are owned/readable by the hls user that I've set to run the server.

    Anyone seen this before?
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    I have not run into that error before. You should ask joev, this is more his realm...sounds like a C error of some kind.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • Rotten_FleshRotten_Flesh Join Date: 2002-11-18 Member: 9203Members Posts: 272
    I changed machines and now when i update steam i get the following message:

    CODE
    Checking bootstrapper version ...
    Creating Account
    AuthenticationServerRSAPublicKey failed signature verifcation


    I tried deleting the bin and steam files and downloading them again and it still shows this message. I've been trying for 2 weeks.
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    edited March 2004
    Do a:

    CODE
    rm -rf ~/.steam


    Then try re-updating.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • Rotten_FleshRotten_Flesh Join Date: 2002-11-18 Member: 9203Members Posts: 272
    I removed it and it still says same message.

    Do you have a link to the new version?
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    Nope, try removing the .blob file and reupdating again. I don't have the new version, I don't think they have released a new steam tool, they only update the old one.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • Rotten_FleshRotten_Flesh Join Date: 2002-11-18 Member: 9203Members Posts: 272
    Now its doing something new:

    First after i create the account (which already exists; so i can update steam) it says:

    CODE

    Checking bootstrapper version ...
    Creating Account
    Connection Reset


    Than when i do it again:

    CODE

    Checking bootstrapper version ...
    Creating Account
    AuthenticationServerRSAPublicKey failed signature verifcation

  • Rotten_FleshRotten_Flesh Join Date: 2002-11-18 Member: 9203Members Posts: 272
    I looked through steam forums, and many other people are having same problem.

    I tried their methods and it still doesn't fix.

    http://www.steampowered.com/forums/showthr...light=.%2Fsteam
  • Rotten_FleshRotten_Flesh Join Date: 2002-11-18 Member: 9203Members Posts: 272
    edited March 2004
    Ok then ....

    I finally got steam to update.

    But now the server crashes with the following error:

    QUOTE
    ./hlds_run: line 57:  4237 Segmentation fault      $HL_CMD
    Add "-debug" to the ./hlds_run command line to generate a debug.log to help with solving this problem
    Mon Mar 22 16:14:29 CST 2004: Server restart in 10 seconds
    ./hlds_run: sleep: command not found


    I've tried re-installing and it still doesnt fix it.

    Btw, this is without any mods, no metamod, no plugins; just plain ns.
  • bradisbestbradisbest Join Date: 2004-02-28 Member: 26959Members, Constellation Posts: 28
    I execute hlds_1_1120.full.bin (this is what the steam site told me was for dedicated linux servers), and I agree to the license. Then I get:

    Enter 'yes' to accept this agreement, 'no' to decline: yes
    extracting /usr/steam/hlds_l_1120_full.tgz...
    hlds_l_1120_full.bin: error extracting payload, No such file or directory
    [[email protected] halflife]$
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    edited April 2004
    Try redownloading it and follow the guides listed in my sig. My way is a bit different.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • bradisbestbradisbest Join Date: 2004-02-28 Member: 26959Members, Constellation Posts: 28
    edited April 2004
    When I try the screen command, I am told:
    -bash: screen: command not found

    thanks
    Post edited by Unknown User on
  • bradisbestbradisbest Join Date: 2004-02-28 Member: 26959Members, Constellation Posts: 28
    I tried to make my server auto-restart with the crontab, and it starts-up a new server every five minutes, regardless of if one is running or not. Why?
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    1st Question: Because you don't have screen installed. Downlod and install it then it will work.

    2nd Question: If you put it in a cron tab then it will execute the command every time it is scheduled to. If you want to use a cron tab to check to see if the server is running and if it isn't, restart it you need to program a check in. Honsetly you don't need to do that, the hlds_run file does a fine job of restarting the server on a crash.

    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • AtomicAtomic Join Date: 2004-05-21 Member: 28804Members Posts: 1
    I've got a problem running my LAN Linux Server using Suse 8.0 Professional - i know there are never versions but this one works.
    It's the Loadlib: Couldn't find blah blah ns_i386.so error...
    Only i am trying to use metamod, so i have ./addons/metamod/dlls/metamod_i386.so. instead of ns_i386.so
    I am totally sure the path is right and everything.
    Also, the normal ns_i386 file works perfectly for me.

    I already tried every distribution of the rpm packages vadakill posted.
    No one worked because or other needed files of conflicts with already installed packages. sad.gif

    HELP because i am desperate to finally do some metamod asrifle.gif skulk.gif
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    Start a new thread, this thread is about setting up a basic server.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • recongamingrecongaming Join Date: 2004-05-29 Member: 28992Members Posts: 1
    I get this when starting a NS server.

    [[email protected] hl]$ ./start
    bash: /root/.bashrc: Permission denied
    [[email protected] hl]$ Auto detecting CPU
    Using Pentium II Optimised binary.
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/nstest/hl/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 12:49:49 Mar 9 2004 (2693)
    STEAM Auth Server
    couldn't exec language.cfg
    Server IP address 205.209.179.20:27000
    scandir failed:/home/nstest/hl/./platform/SAVE
    ./hlds_run: line 423: 15093 Segmentation fault $HL_CMD
    Add "-debug" to the ./hlds_run command line to generate a debug.log to help with solving this problem
    Sun May 30 08:57:32 PDT 2004: Server restart in 10 seconds
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    Updated Linux Guide for NS 3.2
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • SambaSamba Join Date: 2009-07-21 Member: 68214Members Posts: 2
    edited July 2009
    Hm... maybe you can help me... this come out then i try start ns server..
    i follow your guide -> http://www.vadakill.com/nsguides/linux/steam_ns_32.php
    But then i start hl server it runs and NS not...



    Auto detecting CPU
    Using AMD Optimised binary.
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/hlds/hlds_l/./valve/SAVE
    scandir failed:/home/hlds/hlds_l/./platform/SAVE
    Protocol version 48
    Exe version 1.1.2.1/Stdio (valve)
    Exe build: 15:57:57 Jun 15 2009 (4617)
    STEAM Auth Server
    couldn't exec language.cfg
    Server IP address 162.75.221.30:27020
    scandir failed:/home/hlds/hlds_l/./valve/SAVE
    scandir failed:/home/hlds/hlds_l/./platform/SAVE
    [S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.
    FATAL ERROR (shutting down): Unable to initialize Steam.

    Post edited by Unknown User on
  • SambaSamba Join Date: 2009-07-21 Member: 68214Members Posts: 2
    okey now it works....

    how to do..
    here update tool NEW:


    wget http://storefront.steampowered.com/downloa...supdatetool.bin


    cd ns
    and
    create a text file called steam_appid.txt
    only put the 70 in the first line.



    and create

    mkdir /pfad/your/server/valve/SAVE
    mkdir -p /pfad/your/steam/server/platform/SAVE

    example my mkdir /home/hlds/hlds_l/valve/SAVE


    See Ya
Sign In or Register to comment.