Subnautica Xbox Update Released - Subnautica



  • Stackz072Stackz072 Members Join Date: 2019-01-18 Member: 248938Posts: 1 Fully active user
    edited January 2019
    Alright, so a 'nice' little list of what's been going on with my version of the game and maybe some improvements(?):

    1. Game instability is still quite an issue causing random game or full console lock-ups. This is especially so in Creative when making several bases throughout the map which, though I'm no expert on the subject, tells me it's a memory management issue. This issue comes along-side another issue that has plagued my gameplay.

    2. Saves. Saving the game functions as thus with my game: Click save, game 'pauses' completely aside from a spinning symbol and the word "Saving" displayed, after a few seconds the game continues while the symbol and word continue to display for around 30-45 seconds. Game maybe saves? This has lead to several times over the last couple days where, combined with the seeming memory issue causing random crashes, I lose 3+ hours of gameplay. This has happened in every game mode I have tried and every new game I have opened. I have also had several instances of the game or console freezing up *during* the save process.

    a. This would be a good time to question why autosaving isn't a thing in this game? Considering how bad memory management is on consoles I would personally think that autosaves would be almost necessary in order to keep players. I'm insanely stubborn and a bit of a sadist and I still feel like I've gone way over my usual tolerance when it comes to losing hours and hours of gameplay for silly reasons like not having autosaves in a game requiring such high memory management, especially when that management is not working out correctly.

    3. Cyclops vehicle bay hatch is still not spawning correctly. I've tried to mess with it but I'm at the point where there isn't a single save where I can access a Cyclops with a vehicle and not end up glitched inside the Seamoth or Prawn sitting inside the Cyclops bay. At this point I'd have to play quite a few hours of gameplay just to *try* to replicate the issue again to figure out what's happening on my end and considering the aforementioned that's just not going to happen.

    a. This usually happens when loading a saved game with a vehicle loaded into the Cyclops, however it has occurred without a vehicle loaded during the save. Glitch appears to rely upon loading up the saved game, regardless of whether or not the Cyclops has been used beyond fabrication or whether or not a vehicle is loaded into the vehicle bay in the saved game so long as it is a loaded aspect of the game.

    b. To test this as much as one can on an Xbox One I started a brand new game as Creative, did nothing except fabricate a Prawn, Cyclops, and Seamoth, saved the game and tested to see if the loading bay worked before leaving the game - which it did - then I quit the game and loaded up the save. Loading bay was immediately glitched out upon load. Maybe it's not a memory management issue per se, but when I can't leave my game without it crashing basic mechanics there's a bit of a problem. Seems that the Cyclops can't load into the game as an already existing piece without breaking, it has to be fabricated each time you load up or create a game in order for it to function appropriately. Once fabricated it functions normally until such time as you leave the game, no matter the reason - be it save and load, shut down the console, game update, or crash.

    4. Still having land-masses load up *around* my character or vehicles. Also, especially inside the Aurora, I'm having issues where I am looking at a wall from one angle and see the wall, but another angle the wall disappears and I see nothing but seabed. Although it did lead to an amusing show with a Reaper Leviathan that seemed to think I was in it's waters it gets to be extremely distracting at best when I can't even tell if I'm against a wall in the Aurora or where the next hallway I need to go down is.

    5. Speaking of the Aurora, there's a few doors that don't seem to want to function. It's the most inconsistent of these issues so it may be more my own game and system than anything else but all things considered I'm starting to think it ties in with the memory issues that are at least linked to most if not all of my other issues.

    Essentially what I'm saying is: Every. Single. Playthrough I attempt of this game is evidence that this update did little-to-nothing to solve nearly any of the problems it was supposed to fix. Except maybe the Reefbacks but that's more because I'm not sure if "erratic behavior" is what you can call a Reefback hanging out in a Kelp Forest that reaches *maybe* 50m deep at the absolute lowest. I've seriously watched them just float by in areas I wouldn't even bring the Cyclops in Creative. Weird, but unsure if that's what one might call "erratic behavior". Amusing and confusing, to say the least.

    I want to point out that restarting the game, uninstalling and reinstalling the game, and all other 'fixes' I've attempted thus far have done nothing to fix these issues. I am now stuck with several saves where my Cyclops doesn't work even though when I saved it *did* work, and it's not fixing no matter what I do with it. The same can be said for all the other issues I have, though the loading land-masses seems to do a lot better without extensive, consecutive hours of gameplay.

    On a positive note: the Floaters work appropriately and I have used the Feedback button a few times, though I'm not sure it's working how it should. Not that I'd have any way to know if it is working considering there are no responses yet, but I don't expect those to be quick anyway as it takes time to look into feedback on errors, glitches, and other issues.

    Oh...and, the game supposed to be displaying update 84 on the main menu screen as if that was what was most recently released? Because it's really weird looking at an 11 month old update as if it was released 01-03-2019.

    As far as I can tell I have tested what I can as much as I can. Some issues are constants, some are just affected by save/load processes. Others seem more random and others still are more just weird than they are actual bugs or problems as far as I can tell. But the issue I'm having is that this game is supposedly finished and in full release, as far as I have been able to gleam, and is still in pre-release state. Whether that be how unstable it is on the Xbox One, or how unstable the Cyclops' programming seems to be in regards to loading into an existing save.

    The landscape is beautiful, the creatures are amazing. But the game is not a finished product - unless, of course, you're attempting to emulate EA in doing a full release of a game still in pre-release state. As far as I can tell from what I've seen on this site that is far from what you're attempting. But it's still a rather rough experience, to put it lightly, playing this game as a 'full release' in it's current state. The experience of exploration, discovery, and lore finding are great and the environment is beautiful when it works properly and actually loads correctly. But to say that it has been an experience I feel is worth-while of a full release game is stretching things into the boundaries of blatant fallacy. And due to the broken functions of the Cyclops playing any game mode that includes health, death, and depth pressure becomes very hard to manage. And that's just going into the things that are addressed by this update.

    The only other complaint I've had is that early-game methods of finding and producing and keeping enough water and food to survive is extremely hard for the Xbox One version and I have found myself having more trouble than I should progressing forward after 30-40 minutes of gameplay. But that isn't an issue addressed by this update and, honestly, is something I have been learning ways to get around through Creative - when the game isn't crashing every 30-60 minutes and equipment is working correctly.

    EDIT: This was made over the course of a full day or so. If there is anything about this comment that doesn't make sense or is confusing I'll happily clarify or edit this comment in order to make it easier to understand. Nothing in this is meant to bash the game or the developers, merely to provide insight into the problems I've been having and the perspective I have on how this affects the game and my willingness to play.
  • Kid_Hosey421Kid_Hosey421 OhioMembers Join Date: 2018-12-11 Member: 245489Posts: 7 Fully active user
    Still cant get passed the main screen..... I went and bought hard copy of the game thinking that would fox it and nothing!!! Been like this since before Christmas!! WTF is problem? I have twice as much into a game that wont let me pass the main screen... GREAT!
Sign In or Register to comment.