[Bug] Prawn Suits still can glitch through ground and other objects

WhiteShadow2355WhiteShadow2355 Join Date: 2018-07-05 Member: 241943Members Posts: 2 Fully active user
I'm playing on the latest Sept, 2018 version and several issues with the prawn suits still exist even this late into the game's development. I don't expect it to be fixed for the main game but I would hope they would at least look into it for the upcoming stand alone DLC.
The Prawn Suits on several occasions will fall through the floor when traversing certain areas. One that comes to mind is walking along the bottom of the brine pits in The River. I've also encountered issues where I could glitch into ship wreckages before the entity could load all the way and once it had loaded it would trap my Prawn Suit inside of it.
In the instance where I haven't saved in a good amount of time, these glitches could cause the lose of several hours of play. Not to mention being forced to abandon ship while being that deep would undoubtedly end with my character drowning.
Over9000BPMtoon2001jdw805

Comments

  • Over9000BPMOver9000BPM Join Date: 2019-01-06 Member: 248189Members Posts: 19 Advanced user
    Same here. 🙁
  • Nickguy5467Nickguy5467 California Join Date: 2019-01-11 Member: 248505Members Posts: 1 Freshly registered user
    I have this happen quite often too.. my prawn suit falls through the sea bed so far that it cant float up again and i have to go back to my previous save which often is like 20 minutes ago where i had already done so many things that i now have to redo. be nice is devs would adress and fix this issue already.
  • RadonRadon Canada Join Date: 2019-01-11 Member: 248506Members Posts: 1 Freshly registered user
    edited January 11
    I am trapped in my prawn because it glitches through the floor and when I went to quit I had saved now I have to delete my save and start a new game this is really annoying please fix this the prawn had already drained energy but for some reason I can move up and down and my oxygen doesn’t drain and I’m on freedom (PS4)
  • madsaucemadsauce San Francisco Join Date: 2013-06-02 Member: 185442Members, Super Administrators, Forum Admins, Reinforced - Shadow, Subnautica Developer, Subnautica PT Lead Posts: 139 admin
    Is anyone having this issue on PC right now? We have some improvements to the world streaming that should help out on the console side(in the next patch), and an unrelated(similar symptom) where freshly constructed PRAWNs should no longer fall through the world(along with other droppable items). These are being tested now, and will be in the next console patch.
    Near Lethal Damage
  • VegetableWizardVegetableWizard Join Date: 2019-01-12 Member: 248588Members Posts: 1 Freshly registered user
    I'm having this issue on PC still - I've fallen through the floor in my PRAWN a couple of times. I'm using the latest version of the game (September 2018)
  • SRGunnerSRGunner Utah Join Date: 2019-01-12 Member: 248607Members Posts: 1 Fully active user
    Just happened to me on PC - A Reaper Leviathan picked me up in my PRAWN and dropped me through the floor. Not a huge deal; just load the save and repeat last 30 min or so. Minor annoyance right? Only problem I'm struggling with: is the time capsule I'd picked up during that time. I don't know how they work but I guess I can't get that same one again? It had 4 mods for the Seamoth that were going to be huge game-changers for me as I currently have 0 mods. When opening the capsule a second time it just had some melon seeds. Reloaded the save and when opening the capsule for the third time, (and every subsequent time (I've tried roughly 10 times)) it has nothing but the miniature Aurora decoration. I've attached an image of the PDA for it.(guess i can't post links yet) Any knowledge on this would be greatly appreciated as I'm thoroughly confused. Also this is my first forum post so if I'm being dumb or in the wrong spot let me know. :#

    (image might be potential spoiler *shrug*)
  • pepsi_max2kpepsi_max2k Join Date: 2019-01-12 Member: 248630Members Posts: 1 Freshly registered user
    edited January 12
    I just had this on PC. Relatively new Prawn, tried to walk through a gap, got stuck (a bug in itself), got out and swam back to base. Swam back to the prawn and the entire scenery square it was in was invisible. Got back in the Prawn, immeditely started sinking down below the ground (or rather, lack of ground as it were). Restarted and the scenery square is back, just with the prawn stuck underneath it.

    Fun times.
  • jdw805jdw805 SoCal Join Date: 2019-01-12 Member: 248633Members Posts: 3 Freshly registered user
    I just started playing the game a couple weeks ago and I have fell through the floor a couple times in my Prawn Suit.
  • madsaucemadsauce San Francisco Join Date: 2013-06-02 Member: 185442Members, Super Administrators, Forum Admins, Reinforced - Shadow, Subnautica Developer, Subnautica PT Lead Posts: 139 admin
    Thank you all for the info/follow up.
    Near Lethal Damage
  • subnauticambriansubnauticambrian U.S. Join Date: 2016-01-19 Member: 211679Members Posts: 847 Advanced user
    Just finished (today) a full playthrough of subnautica on PC (running latest version), and this bug happened to me at multiple points in my run. Always triggered by me falling too fast for the ground to load and falling through the world. hopefully that helps
    Paleo/Bio nerd. Big fan of Subnautica, particularly the creature design.
  • PhantomcassandraPhantomcassandra Join Date: 2019-05-15 Member: 252899Members Posts: 1 Fully active user
    Just recently redownloaded Subnautica and was basically forced to uninstall it. I have lost probably 5-6 PRAWN suits now due to this issue still being in effect and when I'm getting into the storyline and exploring I forget to save every 5 minutes. Really frustrating and I honestly just uninstalled it since I can't progress in the story at all at this point. All I had left was to cure myself which I couldn't do because heyyy I fall through the earth every 5 minutes. I noticed it happens a lot with the jet upgrades and grappling suit upgrades.
  • vinciblecoinvinciblecoin puerto rico Join Date: 2019-12-01 Member: 256057Members Posts: 1 Freshly registered user
    My dudes its 2019 and i just lost hours worth of game play due to my prawn suit getting glitched inside the sea bed.

    Not only that but my second prawn suit was pushed inside the giant gun structure in the island by a leviathan,to make matters worse. the leviathan gained the power to go through walls and yes you guessed it "fly". WTAF man

    And to clarify this is the console version.
  • JepserpJepserp Sweden Join Date: 2019-12-01 Member: 256066Members Posts: 1 Fully active user
    Hey! Similar problem as @vinciblecoin my Seamoth with a bunch of upgrades got pushed underground by a leviathan and I can't get it up. Searched for people with the same problem and their solution was to go to F1 > Clip mapping > Suspend meshing. Buut it seems that the version that I'm running doesn't have that option. It has basically caused me to stop playing cause I don't feel motivated to get all of that back cause of a bug. I really want to play the game cause it's so amazing, is there any way that I can retrieve it? (Not sure if this is considered off topic but it is my first post so i couldn't make a new topic) Thanks in advance :)
  • cire623cire623 Join Date: 2019-12-07 Member: 256210Members Posts: 1 Freshly registered user
    Still happening on ps4 holes in the floor are very common and just lost my prawn suit because of it
Sign In or Register to comment.