"server Not Responding"

blackholedreamsblackholedreams Members Join Date: 2004-02-04 Member: 26023Posts: 179
...
OK, so I'll admit I'm a bit of a newbie as far as running a dedicated server goes. However, I looked at Vadakill's guide and followed it and got one up and running on another PC in my house. I'm using the command line based HLDS, and run my server with a batch file. I've had several of my friends on it and had no problem with it. I stopped using it for a few weeks (2 or 3) and now tonight I tried running it again. My friend has the server stored in his favorites, but when he tried to join it said my server had a ping of 2000 and wasn't responding. Now, I was running around inside my server(from the computer I usually play on) and everything seemed fine. So my question is, why has it randomly stopped working and what can I do to fix it? (also, I ran hldsupdate tool again but that didn't help...)
IPB Image

Comments

  • DEADscottDEADscott Members, Constellation Join Date: 2003-03-29 Member: 15022Posts: 663
    Running on a cable modem? Has your IP changed?
    DEADCLAN'S NS 3.0.3
    67.19.81.77:27015

    DEADCLAN'S POA
    67.19.81.75:27015

    DEADCLAN'S HL2DM
    67.19.81.74:27015

    http://www.deadclan.com
    #deadclan
  • VadakillVadakill The Almighty BSO Members, NS1 Playtester Join Date: 2002-04-02 Member: 373Posts: 874
    edited March 2004
    That kinda points to a connection issue. Lets lay it out, shall we? You played a few weeks ago and everything worked fine. You left the machine off collecting dust until a couple days ago. Now, when you start the server, you can join and run around and other people can see the server but, when they join the pings go up to 2000. To me that sounds like a internet connection issue.

    Try running a bandwidth test to see if your upstream has changed significantly. Also, make sure you aren't using the connection for anything else...no bittorrent/kazaa/pr0n downloads going on in the background for ANY of the machines on your network.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • DEADscottDEADscott Members, Constellation Join Date: 2003-03-29 Member: 15022Posts: 663
    2000 ping and not resonding......


    Bet hes on a cable modem and his IP has changed.
    DEADCLAN'S NS 3.0.3
    67.19.81.77:27015

    DEADCLAN'S POA
    67.19.81.75:27015

    DEADCLAN'S HL2DM
    67.19.81.74:27015

    http://www.deadclan.com
    #deadclan
  • blackholedreamsblackholedreams Members Join Date: 2004-02-04 Member: 26023Posts: 179
    IP is still the same...nothing that would take up significant bandwidth other than steam has been on. Um, I saved my IP in a text file back when it was working, and according to various sites that tell you your IP, it hasn't changed. Also, this may be the problem, so help me see if I got this worked out right. In my command line I'm currently using my internal IP in the +ip part. If I use the external IP I get an error. If I don't put in an IP, I get a strange IP that isn't part of my internal network (192.168.0.xxx) nor is it my external IP.
    IPB Image
  • blackholedreamsblackholedreams Members Join Date: 2004-02-04 Member: 26023Posts: 179
  • DEADscottDEADscott Members, Constellation Join Date: 2003-03-29 Member: 15022Posts: 663
    Well theres not alot of help I can give you. If you had the server running and players could see it before, and now no one can see it, something has changed.

    What is it? Your IP is the same. That would have been the easy one. Is this just 1 friend, can you see it from another machine? I would check that first, maybe somethings wrong on his/her end. Have him/her delete it from their favorites and try again.

    If thats not it, make sure you have the latest updates to hl/ns/steam on the server. Then comes the fun part. Pull the guide back up and double check your settings. Its the little stuff. Step by step.

    Like I said something has changed, you need to find out what it is. I know of no quick fix.
    DEADCLAN'S NS 3.0.3
    67.19.81.77:27015

    DEADCLAN'S POA
    67.19.81.75:27015

    DEADCLAN'S HL2DM
    67.19.81.74:27015

    http://www.deadclan.com
    #deadclan
  • blackholedreamsblackholedreams Members Join Date: 2004-02-04 Member: 26023Posts: 179
    I've had about 5 people attempt to connect, 3 of whom had my server in their favorites before. I dunno what the deal is, but I'm going to try to get to the bottom of it tomorrow.
    IPB Image
Sign In or Register to comment.