Traped in Cyclop is still here

jerybass12jerybass12 Quebec Join Date: 2017-02-05 Member: 227651Members
edited January 2018 in Subnautica Bug Reporting
So i spended over 13hours to finally craft out that cyclop and everything was alright until I started to drive a bit with it then my animation got struck and I couldnt move beside the camera.I could , power the engine wich was weird, but still cannot move even though i spammed the hell out of (E).I tryed to warp myself somewhere else and fun fact, the submarine actually warped with me XD So i gave up and came here to know how I can fix that..Because i must have lost more than an hours of gameplay due to that


  • mfo291mfo291 United States Join Date: 2018-01-06 Member: 234835Members
    I have experienced the same thing and I created my Cyclops before the recent updates (I am on the experimental builds). I have to exit to the main screen and reload my save for me to drive the cyclops again...for a few seconds and then the Cyclops stops and clicking the 'E' does nothing, so I have go back to the main screen again. Seamoth and the Prawn suit does not do the same thing.
  • muaddiibmuaddiib Ukraine Join Date: 2018-01-06 Member: 234841Members
    have a same issue, reported to f8
  • MadCJRMadCJR Join Date: 2018-01-06 Member: 234852Members
    Same thing here also in experimental mode. Could it possibly have something to do with the vehicle docked inside or the upgrades?
  • muaddiibmuaddiib Ukraine Join Date: 2018-01-06 Member: 234841Members
    posible, after 4 jan update
  • SkodenSkoden USA Join Date: 2018-01-05 Member: 234821Members
    Hey! Same for me! After a few seconds of attempted cyclops piloting the driver gets super glued to the steering wheel. Looks like another weekend of PUBG!
  • PKingZombieSpyPKingZombieSpy United States Join Date: 2018-01-07 Member: 234886Members
    I think I have the same issue. Jan 2018 58835 build seems to have a bug for me whereby when I drive a cyclops for about ten seconds:
    • All keyboard game input is suspended. You cannot even exit the cockpit by pressing E.
    • If you happened to be turning at the time, your "arms" are frozen in that position.
    • The noise level is "stuck" on whatever that was.

    I am on the experimental build, with a cyclops I just built. This is a survival game I started yesterday. It happens both with and without a vehicle in the bay.

    I'm unable to find a workaround short of not using the cyclops, which, considering where I am in the storyline, I kind of have to. Reloading/restarting Subnautica/exiting-the-cyclops/etc. does not cause the problem to resolve itself. The Cyclops is, it seems, unusable.

    I have made a video to illustrate the problem. The forum software is not allowing me to post links because I haven't been "around long enough," (!!??) so this is the *partial* URL (in code blocks because that's the only way I can provide information): Prefix with an "https" and you will have the URL. :(

    At 13 seconds I begin driving. At 23 seconds the cyclops keyboard input is suspended. Note the "noise" level being frozen (most visible at 30 seconds). I can still use the mouse as you see.
  • baritonusbaritonus Join Date: 2018-01-06 Member: 234855Members
    I have the same problem as well.

    It seems like the bug was introduced in the January 4th update, and the January 7th update didn't fix it. I've reproduced the bug on build 58835 as well.

    Saving/reloading does solve the problem for about 10 seconds, but it repeats every time.

    Here's what I tried to fix it.
    Having Seamoth/Prawn/nothing in the loading bay
    Unloading all power cells then reloading 1 (With no power cells, the Cyclops shows -2147 power at the helm though)
    Removing all placable objects
    Removing all upgrades

    When stuck to the steering wheel, you can still use the camera to look around and interact with the helm UI including external cameras, but you can't accelerate, turn, or exit the Cyclops helm.

    PKingZombieSpy's video pretty much sums it up though.
  • KirdKird Poland Join Date: 2018-01-07 Member: 234892Members
    Same issue. Anyone found any workround for this?
  • PKingZombieSpyPKingZombieSpy United States Join Date: 2018-01-07 Member: 234886Members
    edited January 2018
    I've tried a number of things. No luck. Building a new Cyclops, piloting using only the cameras, piloting entirely backwards, many permutations of turning on the sub, stepping away, stepping off, stepping back on again, nothing. Driving only three seconds at a time before stopping, stepping away from the controls, then stepping again, before doing another three seconds will also hit the bug after perhaps three or four tries.

    I can, I notice, spin in place as long as I like. :) And if I move forward/backup repeatedly I can "drive" also as long as I like, so long as I'm careful not to go more than twenty or thirty meters from where I started. But whenever I start trying to go anywhere and move too far from the starting position it says to me, "OK, you've had enough" and I hit the bug. :)

    On the positive side: it happens even with a fresh creative mode save where I spawn in a sub with `sub cyclops`, so it is very, very easy to repro. Hopefully it is as easy to fix as to repro. :) Though I notice no bug matching this description is in Trello, so I wonder if they're aware of it. But perhaps I misunderstand what they use Trello for. Welcome to early access, I guess! :D

    Edit: I see the build number has changed from 58835 this morning to 58854. The issue still persists.
  • ZeoranZeoran Join Date: 2018-01-05 Member: 234815Members
    Same problem here, with the latest build just tested it again and again, after 15 seconds of driving, everything simply stops. I don't understand how this isn't a TOP priority for them now. I understand we're playing experimental and I expected (and have experienced many) bugs while playing but NONE of them have been as GAME STOPPING as this one. You LITERALLY cannot play while this bug exists unless you chose to never use a Cyclops, which just defeats 2/3 of the whole bloody game. I would REALLY like to hear from the devs on this and they better not come back with a "don't play on experimental if you don't like bugs" comment. This is beyond a normal "bug".
  • 0x6A72320x6A7232 US Join Date: 2016-10-06 Member: 222906Members



    58861	/main	2018-01-08 01:33:13	David Kalina	Fixed Cyclops LOD bug resulting in broken controls after driving. Fixed Type.ToString garbage in profiler tags. BehaviourLOD cleanup.
    58860	/main/dk-fixCyclopsBehaviourLOD	2018-01-08 01:27:52	David Kalina	Moving recent LOD cleanup and fixes to new branch
    58858	/main/dk-powerRelayOptimization	2018-01-08 01:08:46	David Kalina	If BehaviourLOD specifies a boundsRenderer to use for distance checks, it updates the bounds from the renderer in every frame. 
     This fixes the cyclops controls breaking - previously, any driving of the cyclops would leave the LOD bounds behind, resulting in unwanted low-LOD behavior (like not being able to steer or exit the cyclops).
  • muaddiibmuaddiib Ukraine Join Date: 2018-01-06 Member: 234841Members
    edited January 2018
    have a 854 build, where 861? :)
  • 0x6A72320x6A7232 US Join Date: 2016-10-06 Member: 222906Members
    muaddiib wrote: »
    have a 854 build, where 861? :)

    Probably the next one to be pushed (I don't think they push an update for every patch)
  • PKingZombieSpyPKingZombieSpy United States Join Date: 2018-01-07 Member: 234886Members
    edited January 2018
    Awesome. Thank you for pointing this out, um, jr2. I had no idea they had a public commit log. Last night it was 58854, but I see this morning there is an update, and it is... 58873. Sweet. :) Yes, and the Cyclops works again!!
  • MadCJRMadCJR Join Date: 2018-01-06 Member: 234852Members
    Either I got lucky this time or the problem is fixed. I went in to check the problem today and the cyclops appeared to be driving as normal now. Will post again if it stops working.
  • ZeoranZeoran Join Date: 2018-01-05 Member: 234815Members
    The problem (as of today's build) is finally FIXED. Thank you Devs!!! I can actually play again!!!
  • SarellionSarellion Join Date: 2017-09-23 Member: 233194Members
    Well, it broke completely for me. The savegame where I saved in the Cyclops doesn´t work at all. Starts, can´t move and then I get a system message that Subnautica doesn´t work.
Sign In or Register to comment.