Get kicked back to main menu after trying to connect to a server.

CycloneCyclone Members Join Date: 2013-02-15 Member: 183099Posts: 12 Fully active user
Every time I join a server, it kicks me back to the main menu partway through connecting. (It used to say "mod error", but now I'm just looking at the background without any of the buttons, screenshot attached)
I've tried deleting my steam workshop folder, deleting my system options, and deleting my remote options files to no avail. This started happening after Valve updated their mod stuff, and did not resolve following patch 320. Also attaching my Techsupport.exe file. Any help would be greatly appreciated!
lsz7uklithc8.png

Comments

  • BeigeAlertBeigeAlert TexasMembers, Super Administrators, Forum Admins, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, NS2 Map Tester, Reinforced - Diamond, Reinforced - Shadow, Subnautica Playtester, Pistachionauts Join Date: 2013-08-08 Member: 186657Posts: 2,829 admin
    Hey @Cyclone !

    It looks like a couple of files didn't update correctly.
    Please verify your files with Steam.
    - Right click Natural Selection 2 in your Steam library, and choose "properties".
    - In the "local files" tab, choose "verify integrity of game files".
  • CycloneCyclone Members Join Date: 2013-02-15 Member: 183099Posts: 12 Fully active user
    edited December 2017
    Already tried that, still no dice :[ I'll run a fresh install tonight and let you know if that works.
    Edit: Fresh installed, still no change. Get booted back to the main menu during the "Checking Game Files" step every time.
    Post edited by Cyclone on
  • CmdrKeenCmdrKeen Members, Reinforced - Shadow Join Date: 2013-05-21 Member: 185321Posts: 83 Advanced user
    edited December 2017
    I am not sure if it is the same error, because I do not see the bugged out menu screen like @Cyclone, but I cant join any server currently. There is an error message in console about a "different amount of network messages on the client from the server". I think I also saw some NS2+ related errors (unable to open some files with CHUD_*filename*) but I could not reproduce those errors.

    Edit:
    Things I already tried are * workshop deleted * system_options delete * remote options delete * verify game files * try beta branch

    Edit2: I got the CHUD errors again, see tech_support2.zip
    Stark
  • GhoulofGSG9GhoulofGSG9 Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Join Date: 2013-03-31 Member: 184566Posts: 2,838 admin
    CmdrKeen wrote: »
    I am not sure if it is the same error, because I do not see the bugged out menu screen like @Cyclone, but I cant join any server currently. There is an error message in console about a "different amount of network messages on the client from the server". I think I also saw some NS2+ related errors (unable to open some files with CHUD_*filename*) but I could not reproduce those errors.

    Edit:
    Things I already tried are * workshop deleted * system_options delete * remote options delete * verify game files * try beta branch

    Edit2: I got the CHUD errors again, see tech_support2.zip

    Delete the workshop folder another time and avoid the server you connected first to in the past. Most likely given server is the one distributing the corrupted ns2+ version via it's workshop backup server.
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
  • CmdrKeenCmdrKeen Members, Reinforced - Shadow Join Date: 2013-05-21 Member: 185321Posts: 83 Advanced user
    @GhoulofGSG9 Yep! That fixed it. Thank you. The server I joined first was one of the NS2RU servers. I'll try to contact @artem, although I do not have him in steam friends yet.
Sign In or Register to comment.