Ns 2.0 Server Crash On Start (linux)

akolinareakolinare Join Date: 2003-08-06 Member: 19047Members Posts: 8
HI,

I look around but nobody seems to have this problem I have.

I installed ns server 2.0 on hl server 3.1.1.1.d. I applied also the patch required for this hl version. The hl and cs server work fine but the ns server crashed with the following debug.log :

CRASH: Wed Aug 6 10:03:22 CEST 2003
Start Line: ./hlds_amd -game ns -debug +ip xx.xx.xx.xx +port xxxxx +sv_lan 0 +maxplayers 20 +map ns_nothing.bsp
Core was generated by `./hlds_amd -game ns -debug +ip xx.xx.xx.xx +port xxxxx +sv_lan 0 +maxplayers 20'.
Program terminated with signal 11, Segmentation fault.
[New Thread 1024 (LWP 27434)]
#0 0x0 in __strtol_internal (nptr=) at eval.c:35
#0 0x0 in __strtol_internal (nptr=) at eval.c:35
End of crash report

Some server data :
cpu Athlon 2400+
linux kernel 2.4.21
dist slackware
hl 3.1.1.1d
ns 2.0


Can anybody help me ? Thanks a lot !

Comments

  • easy_targereasy_targer Join Date: 2003-08-09 Member: 19256Members Posts: 3
    QUOTE (akolinare @ Aug 9 2003, 04:29 AM)
    ./hlds_amd -game ns -debug +ip xx.xx.xx.xx +port xxxxx +sv_lan 0 +maxplayers 20 +map ns_nothing.bsp

    is this your command line? if not what is it?
  • akolinareakolinare Join Date: 2003-08-06 Member: 19047Members Posts: 8
    i think so. I choose hlds_run instat hlds_amd. I try to the command with hlds_amd. The debug.log is the same.

    I just upgraded to server version v201c. Without success. Excactlly the same debug.log is the result.

    The consol logging after start looks like this :

    Console initialized.
    Protocol version 46
    Exe version 3.1.1.1
    Exe build: 18:21:32 Jul 29 2003 (2469)
    WON Auth Server
    Server IP address xx.xx.xx.xx:xxxxxx
    LoadLibrary failed on ./ns/dlls/ns_i386.so: ./ns/dlls/ns_i386.so: undefined symbol: inflateEnd
    Host_Error: Couldn't get DLL API from ./ns/dlls/ns_i386.so!
    FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from ./ns/dlls/ns_i386.so!

    Segmentation fault
  • joevjoev Giving grief... With a smile. Join Date: 2002-07-20 Member: 977Members, Retired Developer, NS1 Playtester, Contributor, Constellation, Reinforced - Shadow Posts: 1,086
    edited August 2003
    try taking the .bsp off the map name.

    The original 2.01c .so is borked. use this one:

    http://www.natural-selection.org/files/ns_...2.01c-fixed.zip

    joev.
    Joe Vaughan ([email protected]) -- Old foagie -- Bragging rights: Development Director of Natural Selection I
  • cgountaniscgountanis Join Date: 2003-08-10 Member: 19314Members, Reinforced - Gold Posts: 61
    Are the 2.0 clients compatible with the new 2.01 server? Does it fix the server running insecure mode? My CS server has no issues downloading the security modules and going secure...
  • akolinareakolinare Join Date: 2003-08-06 Member: 19047Members Posts: 8
    I try the to start the server without .bsp. The same. But if I try it without a map the message line with the server IP adress is the last line print out. And nothing else more. No further startup but also no crash.

    With the new patch it is the same as with the old one.

    Is this only a ns problem, ? Other server running with the same software version. Operating system problem ? I dont hope.
  • akolinareakolinare Join Date: 2003-08-06 Member: 19047Members Posts: 8
    is there anywhere a list of all md5 sums for the ns files available ?
  • akolinareakolinare Join Date: 2003-08-06 Member: 19047Members Posts: 8
    edited August 2003
    OK I installed the hlds server 3.1.1.1 and the ns 2.0. no problem. No crash, but after the server contact the Won server nothing else happens. The server freeze like this :

    ########################################
    Auto-restarting the server on crash

    Console initialized.
    Protocol version 46
    Exe version 3.1.1.1
    Exe build: 22:35:19 Apr 29 2003 (2378)
    WON Auth Server
    Server IP address xx.xx.xx.xx:xxxxx
    Adding Auth server 65.73.232.251:27040
    Adding Auth server 65.73.232.253:27040
    Adding master server 65.73.232.251:27010
    Adding master server 65.73.232.253:27010
    Adding master server 65.73.232.252:27010
    #############################################

    After that I installed the hlds patch 3.1.1.1d and then the same crash occur as before.
  • verboseverbose Join Date: 2002-11-25 Member: 9968Members, Constellation Posts: 681
    edited August 2003
    IIRC, 3.1.1.1 doesn't produce any "loading" output after that, not like 3.1.1.0 which goes through a few pages of sprites and whatnot. Does plaing 3.1.1.1 completely hang, or just not produce any more output right away? Type "status" in the console, see if it's responding.

    There's another fellow in the "Hlds Having A Tanty" thread getting a similar error with 3.1.1.1d:
    QUOTE
    LoadLibrary failed on ./ns/dlls/ns_i386.so: ./ns/dlls/ns_i386.so: invalid ELF header
    Host_Error: Couldn't get DLL API from ./ns/dlls/ns_i386.so!
    FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from ./ns/dlls/ns_i386.so!


    Anyone know of any 3.1.1.1d-specific problems?
    Pigeons. Pigeons...are good too. Sometimes, they come with notes attached. It's like a fortune cookie with wings. Squirrels!
  • cgountaniscgountanis Join Date: 2003-08-10 Member: 19314Members, Reinforced - Gold Posts: 61
    I did have same error. Make sure you stick with 2.0 and unzip ON THE LINUX box without any commands like -a. I couldn't get 2.0c to work and since it's beta better not use yet. Many complaints and issues with 2.0c. Delete the ns directory use wger to get the files reinstall ns and patch. Try running the hlds_run with the proper command. Are you running as root or maybe instaling as root and running as non-root user? Just try the server without metamod if your using metamod untill you get it working. I had no issues with 2.0 but soon as I did the 2.0c all kinds of issues. Unzip everything from the linux box and when you do patch make sure your renaming to the proper ns_i386.so.

    Go to the hlds_l directory and run this (change port to whatever you use):
    /hlds_l/hlds_run -game ns -port 27017 +maxplayers 18 +map ns_nothing
  • saubloedsaubloed Join Date: 2002-11-02 Member: 3996Members Posts: 112
    edited August 2003
    QUOTE (akolinare @ Aug 10 2003, 12:08 PM)
    is there anywhere a list of all md5 sums for the ns files available ?

    Just check the so file - i use that one for hlds 3.1.1.1:
    8ac2133b75e8683c7d8dde1097713f01 ns_i386.so

    And do NOT use beta NS files. None of them worked for me.
  • akolinareakolinare Join Date: 2003-08-06 Member: 19047Members Posts: 8
    edited August 2003
    thank you. I unzip the file without any commands, as descripted in the newbie faq. I try to start and installed as root and also as other user.

    I only installed the hlds 3.1.1.1 and the ns_v2 server. Nothing else., no patch, no fix, no addition software like metamod.

    But the server freeze after contact the server . Here are the last famous word :

    Adding Auth server 65.73.232.251:27040
    Adding Auth server 65.73.232.253:27040
    Adding master server 65.73.232.251:27010
    Adding master server 65.73.232.253:27010
    Adding master server 65.73.232.252:27010

    the original ns dll has the following md5sum ? It is the one from the ns_v2_dedicated_server.tar.gz
    f15053e960fe197ffd1f1d77d4995cc7 ns_i386.so
  • saubloedsaubloed Join Date: 2002-11-02 Member: 3996Members Posts: 112
    QUOTE (akolinare @ Aug 11 2003, 09:15 AM)
    thank you. I unzip the file without any commands, as descripted in the newbie faq. I try to start and installed as root and also as other user.

    I only installed the hlds 3.1.1.1 and the ns_v2 server. Nothing else., no patch, no fix, no addition software like metamod.
    (...)

    From the download page: http://www.natural-selection.org/downloads.html

    To run NS 2.0 on Linux with HLDS 3.1.1.1, you'll need to download this patch (check the Server Op forum for more information and updates).

    http://www.natural-selection.org/ns_i386-3.1.1.1.so.gz
Sign In or Register to comment.