Beta 2.0c And Linux

FlummiFlummi Join Date: 2003-01-10 Member: 12143Members Posts: 28
Server crashes
I just tried to install the beta 2.0c on a Linux Server and Im getting this error

./hlds_run: line 339: 26435 Segmentation fault $HL_CMD


Who has an Idea how to solve this?

Comments

  • wendigowendigo Join Date: 2002-11-13 Member: 8371Members Posts: 75
    edited August 2003
    NM
    ClanCF NS:C Only - 38.113.32.172:27015
    ClanCF Classic NS Only - 38.113.32.171:27015
    ClanCF NS Barb's Haus of Pain 24.175.230.84:27015

    http://www.clancf.net
  • Eternal_BlissEternal_Bliss Join Date: 2002-11-07 Member: 7633Members, NS1 Playtester, Contributor Posts: 442
    It has a bug, it won't run... live with it.
    image[EUPT]
  • SikkemaSikkema Join Date: 2003-05-13 Member: 16260Members Posts: 15
    to bad, finaly a linux version......and it simply crashed my servers.....sigh.......hopefully next time they bring a WORKING version or just no Linux one at all.....'cause this is annoying. mad.gif sad.gif
  • easy_targereasy_targer Join Date: 2003-08-09 Member: 19256Members Posts: 3
    edited August 2003
    im running hlds_l_3111d with ns 2.0 and amx mod without a single crash

    on a athlon 2200 256 ram and scsi3....
  • NecroNecro <insert non-birthday-related title here> Join Date: 2002-08-09 Member: 1118Members Posts: 3,051 Fully active user
    it's beta. flayra's time is going into making it good not a working linux build, linux was just an extra which he hoped would work.
    image
    EUPT
  • joevjoev Giving grief... With a smile. Join Date: 2002-07-20 Member: 977Members, Retired Developer, NS1 Playtester, Contributor, Constellation, Reinforced - Shadow Posts: 1,086
    edited August 2003
    Actually it was just a small error in the makefile Flayra used to build it.

    I've fixed it: http://www.natural-selection.org/files/ns_...2.01c-fixed.zip

    That should hopefully work. (possibly not with HLDS 3.1.1.1(x) though)

    (Sikkema: please take that 'tude somewhere else. We do all this work, practically 18 hours a day for some of us and give you the benefit *free*. Show a little respect.)

    joev.
    Joe Vaughan ([email protected]) -- Old foagie -- Bragging rights: Development Director of Natural Selection I
  • joevjoev Giving grief... With a smile. Join Date: 2002-07-20 Member: 977Members, Retired Developer, NS1 Playtester, Contributor, Constellation, Reinforced - Shadow Posts: 1,086
    *bump* so people see it and stup hassling me smile.gif

    joev.
    Joe Vaughan ([email protected]) -- Old foagie -- Bragging rights: Development Director of Natural Selection I
  • FlummiFlummi Join Date: 2003-01-10 Member: 12143Members Posts: 28
    ./hlds_run: line 339: 10953 Segmentation fault $HL_CMD

    same error with your fixed .so sad.gif

    But thanks for trying to fix it joey wink.gif That was really nice
  • joevjoev Giving grief... With a smile. Join Date: 2002-07-20 Member: 977Members, Retired Developer, NS1 Playtester, Contributor, Constellation, Reinforced - Shadow Posts: 1,086
    QUOTE (Flummi @ Aug 10 2003, 04:43 PM)
    ./hlds_run: line 339: 10953 Segmentation fault $HL_CMD

    same error with your fixed .so sad.gif

    But thanks for trying to fix it joey wink.gif That was really nice

    lemme guess.. hlds 3.1.1.1 yeah?

    /me needs to get the build environment sorted for hlds 3.1.1.1 sad.gif

    joev.
    Joe Vaughan ([email protected]) -- Old foagie -- Bragging rights: Development Director of Natural Selection I
  • FlummiFlummi Join Date: 2003-01-10 Member: 12143Members Posts: 28
    yes you´re right Im using hlds 3.1.1.1d
  • akolinareakolinare Join Date: 2003-08-06 Member: 19047Members Posts: 8
    I think you have the same problem. After I upgraded to 3.1.1.1d the server crashed. I suggest using the old hlds 3.1.1.1
  • SikkemaSikkema Join Date: 2003-05-13 Member: 16260Members Posts: 15
    joev, i mean no disrespect, but it was just very frustrating that my servers crashed. I know its all "freetime" that they work on it. But i'm not the only one that was dissapointed...... confused.gif
  • saubloedsaubloed Join Date: 2002-11-02 Member: 3996Members Posts: 112
    Both 2.0c linux beta versions crashes the server!

    cbdcbfab4b08b7f9ce422fee2fb3531b ns_i386.so

    QUOTE
    Auto detecting CPU
    Using AMD Optimised binary.
    Auto-restarting the server on crash

    Console initialized.
    Protocol version 46
    Exe version 3.1.1.1
    Exe build: 18:21:32 Jul 29 2003 (2469)
    WON Auth Server
    Server IP address ***
    LoadLibrary failed on ./ns/dlls/ns_i386.so: ./ns/dlls/ns_i386.so: undefined symbol: inflateEnd
    Host_Error: Couldn't get DLL API from ./ns/dlls/ns_i386.so!
    FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from ./ns/dlls/ns_i386.so!

    ./hlds_run: line 14: 27135 Segmentation fault      $HL_CMD
    Add "-debug" to the ./hlds_run command line to generate a debug.log to help with solving this problem
    Sun Aug 10 17:43:46 CEST 2003: Server restart in 10 seconds



    "fixed":
    d643283a23ef39d650c836c697222ff2 ns_i386.so

    QUOTE
    Auto detecting CPU
    Using AMD Optimised binary.
    Auto-restarting the server on crash

    Console initialized.
    Protocol version 46
    Exe version 3.1.1.1
    Exe build: 18:21:32 Jul 29 2003 (2469)
    WON Auth Server
    Server IP address ***
    ./hlds_run: line 14: 27161 Segmentation fault      $HL_CMD
    Add "-debug" to the ./hlds_run command line to generate a debug.log to help with solving this problem
    Sun Aug 10 17:45:01 CEST 2003: Server restart in 10 seconds
  • saubloedsaubloed Join Date: 2002-11-02 Member: 3996Members Posts: 112
    QUOTE (akolinare @ Aug 10 2003, 04:49 PM)
    I think you have the same problem. After I upgraded to 3.1.1.1d the server crashed. I suggest using the old hlds 3.1.1.1

    No do not use the older versions than 3.1.1.1d if your server is connected to the internet.

    If you dont know the security holes you should read that:
    http://www.securityfocus.com/bid/8300/info/
    http://www.securityfocus.com/bid/8301/info/
Sign In or Register to comment.