Bad collision volumes and unnecessary invisible walls

CatsyCatsy Members Join Date: 2020-04-19 Member: 260185Posts: 2 Fully active user
Below Zero has a large number of issues with bad collision volumes that simply did not exist in Subnautica, even in the same objects. This especially seems to afflict objects like stairs really badly if you approach them from an off-angle, but this also extends to the small stairs at the connections between hab buildings--I'm constantly getting stuck on them. This is above and beyond the already-excessive amount of invisible walls blocking the player from hopping over railings or blatantly-passable obstacles.

The last straw today was at the excavation site, and the bad collision trapped me between a railing and some rocks. To add insult to injury, I could've bunny-hopped my way over the rocks and saved myself from being trapped if it weren't for yet another unnecessary invisible wall.

There are a lot of good things about this game, but the really buggy collision issues have got to be fixed, they're ruining my ability to enjoy the rest.

Comments

  • JamieLee2kJamieLee2k Members Join Date: 2021-06-03 Member: 271022Posts: 1 Freshly registered user
    I am having the same issue with the stairs that join rooms together, some stairs are fine and some just wont let me in the room without trying for a couple of minutes
  • EksinEksin Members Join Date: 2021-06-03 Member: 271032Posts: 1 Fully active user
    edited June 3
    Hi guys. I have the same problem. And good news I found how to fix this. The bug is related to your high FPS.
    The player stucks between seatruck modules, between base modules, and in some cases (like stairs), on the ground.

    I have 144 hz monitor, so I have 144 fps in the game (vsync or 144 FPS Cap). The easiest way to reproduce the bug in a seatruck. Leave a seatruck tilted. Just walk inside your seatruck, and the player stucks between seatruck modules.
    I tried to raise FPS Cap to 500 FPS. Windows game bar is showing that I have 200-250 fps in the game. Collision issues become just worse.

    To fix this bug, I decreased my FPS. I make FPS Cap lower than 144 FPS. I tried 60 FPS - the problem is 99% gone. I still had an issue few times but in general, it's good.
    I assume that the player's collision is somehow related to FPS. Higher FPS produces more collision issues.
    I reproduced the same bug on a different PC that able to play the game with a high frame rate.

    FPS cap in Options > General, you need to turn off vsync to see this option.
Sign In or Register to comment.