Below Zero: Game won’t launch (Mac Catalina OS, MBP)

MochifiendMochifiend Join Date: 2017-08-20 Member: 232511Members Posts: 9 Fully active user
Happy New Year everyone!

I played Subnautica from early in its Early Access life and Below Zero from its first launch. I have played Below Zero in experimental on an early 2015 MacBook Pro (3.1 GHz Dual Core Intel Core i7, 16 GB ram). However, since 24 December, I have not been able to get the game to load.

Nothing in my computer or network settings have changed.

Initially it gave me an error message in Steam. So I ran through Steam’s troubleshooting tree, eventually uninstalling both Steam and Subnautica completely from my machine. After a reinstall, it get a the game to act like it is starting, but the screen never opens to the main menu. I see a head shot of Sam Goodall for a second, then sounds of marine life start to gurgle, but the game just hangs there. I have tried letting it go for 10 minutes to see if it boots, but nothing.

Any thoughts on what I am doing wrong?

I have one more day of holiday left, and no human engagements to prevent me from playing, so I’d like to get lost in the cold again. Please help.
annirose1

Comments

  • MochifiendMochifiend Join Date: 2017-08-20 Member: 232511Members Posts: 9 Fully active user
    Update on above: I tried a few more things and now neither Subnautica nor Below Zero will launch. I get this: Error Code 4294956486 when I try to launch Below Zero in experimental. Interestingly enough, I can upload game in stable, but I've seen too much to revert to that game right now.

    Also, I tried the suggested terminal fix suggested by another developer for a different game without luck. Another suggestion was to play using Bootcamp on this computer but would prefer a better solution.

    Most likely this is a Steam issue, but they have no way for me to file a ticket for support or fix of the issue. Any thoughts?
    cerise
  • cerisecerise Join Date: 2020-01-05 Member: 256982Members Posts: 1 Fully active user
    hey, I am having the same problem, did you find any solution?
    annirose1
  • annirose1annirose1 Join Date: 2019-11-06 Member: 255328Members Posts: 4 Fully active user
    After 300 hours of Below Zero on my Mac os - both regular and experimental- game won't launch after going through many troubleshooting attempts. Subnautica launches fine. BZ goes from 'error' won't load to going to a black screen and endless 'loading...' with sound effects in background. I read on here and discord that devs were aware of the problem but after weeks- what gives?
    thx
  • annirose1annirose1 Join Date: 2019-11-06 Member: 255328Members Posts: 4 Fully active user
    So what happens after posting here and seeing (here and in discord) others having sudden problems with Below Zero launching on Macs? Is there another way to contact Steam or Devs? SN plays fine and after 300+ hours of Below Zero- just shows 'loading' on a black page. Where do you go next?
  • JoFoRaJoFoRa Join Date: 2020-01-24 Member: 257376Members Posts: 2 Fully active user
    I have also a Mac. Please help.
    Mochifiend
  • MochifiendMochifiend Join Date: 2017-08-20 Member: 232511Members Posts: 9 Fully active user
    Hey there. I am still having issues with Subnautica Below Zero--there is a conversation on Steam, but it is not always clear if I have explained my issues clearly enough to generate a response. I feel a bit lost.

    Here is the latest:
    I can play Subnautica fine in stable and experimental.
    I can play the other unity games on Steam (Oxygen Not Included and Civ6) fine.
    I CANNOT play Subnautica Below Zero on stable--the graphics are wonky, and yes, I have tried implementing the low-resolution option.
    I CANNOT play SBZ in experimental--the game loads and starts with the PDA alarm, but there is no audio. Once Robin sits up in bed, the game freezes and I cannot use the F8 command to report the issue.

    Any help, or guidance, would be appreciated. I am not a coder or developer, so I don't know how to report these issues so they are clear to those who are. Thanks.
  • lancedragonslancedragons Join Date: 2020-02-09 Member: 257740Members Posts: 1 Freshly registered user
    I have macOS Catalina and can't run Subnautica either, it won't even launch the app
    I tried opening the executable and it says this:
    2020-02-09 16:08:19.508 Subnautica[25649:819128] Unable to load the Interface Builder file MainMenu.nib because the object archive is missing. Valid nib files must contain either keyedobjects.nib, objects.nib, or data.nib. Full path: /Users/Shared/Epic Games/Subnautica/Subnautica.app/Contents/Resources/MainMenu.nib
    2020-02-09 16:08:19.508 Subnautica[25649:819128] Unable to load nib file: MainMenu, exiting
    logout
    
  • MochifiendMochifiend Join Date: 2017-08-20 Member: 232511Members Posts: 9 Fully active user
    Okay, so after today's update I am still unable to play in experimental, only this time, I am back to getting the message from Steam that will not allow the game to launch. I am getting OS error 4294956486 again.

    I can, however, now play the stable version of the game. So I tried to start a game in stable, saved it once I was in the water, and change game to experimental to see if the problem was just a hurdle at the start of the game. No luck. I get the error message in experimental.

    Any thoughts?
  • narfblatnarfblat Utah, USA Join Date: 2016-05-15 Member: 216799Members, Forum Moderators, Forum staff Posts: 669 mod
    @Mochifiend I found a couple different posts on that error code. All seem to be the same issue - a Unity update changed how their games make executables(it now includes spaces), so steam shortcuts are broken on Mac's. Refresh the shortcut or create a new shortcut to the path with either of these methods:
    https://forum.unity.com/threads/os-error-4294956486-failed-to-start-process.742928/
    https://steamcommunity.com/app/461430/discussions/0/1457328392101158735/
    Subnautica stuff:
    Official Subnautica discord chat: https://discord.gg/subnautica
    For updates on Console progress for both Subnautica and Below Zero, check the favro page, here.
    How to clear your Cache, by 0x6A7232.
    How to use console commands.
    Stuck, and just want to most recent base/Cyclops? Use "Warpme" command. Want to get out of the ceiling? Press F1 and note your camera postion. First number is North/South, second number is up/down, and third is East/West. Reduce the 2nd number by 10, then use "warp x y z" (where x, y, and z are the position you want to be).
  • MochifiendMochifiend Join Date: 2017-08-20 Member: 232511Members Posts: 9 Fully active user
    edited February 20
    @narfblat Thank you. I read through the links you sent and tried to follow the instructions laid out to correct the issue. I was successfully able to launch the game, but the game still hangs right after Robin turns to get out of bed. Sam never starts talking, I just get a beach ball and a clicking whistle. The game is still unplayable in experimental.

    I have attached my player log here, but I have no idea what it means:
    (Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 35)

    LightmappedPrefabs all loaded, maybe starting intro vignette frame 3466

    (Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 35)

    StackOverflowException: The requested operation caused a stack overflow.
    at (wrapper managed-to-native) System.Runtime.InteropServices.Marshal.AllocHGlobal(intptr)
    at System.Runtime.InteropServices.Marshal.AllocHGlobal (System.Int32 cb) [0x00006] in <599589bf4ce248909b8a14cbe4a2034e>:0
    at FMOD.Sound.getName (System.String& name, System.Int32 namelen) [0x00000] in :0
    at FMODSoundCallback.SoundCallback (FMOD.Studio.EVENT_CALLBACK_TYPE type, FMOD.Studio.EventInstance eventInstance, System.IntPtr parameters) [0x00054] in :0
    at (wrapper native-to-managed) FMODSoundCallback.SoundCallback(FMOD.Studio.EVENT_CALLBACK_TYPE,FMOD.Studio.EventInstance,intptr)
    UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    UnityEngine.Logger:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    UnityEngine.UnhandledExceptionHandler:m__0(Object, UnhandledExceptionEventArgs)
    System.Runtime.InteropServices.Marshal:AllocHGlobal(IntPtr)
    System.Runtime.InteropServices.Marshal:AllocHGlobal(Int32)
    FMOD.Sound:getName(String&, Int32)
    FMODSoundCallback:SoundCallback(EVENT_CALLBACK_TYPE, EventInstance, IntPtr)

    (Filename: <599589bf4ce248909b8a14cbe4a2034e> Line: 0)
Sign In or Register to comment.