Xbox 360 Controller Trigger Buttons Reversed

GranistarGranistar Manchester, NH Join Date: 2019-08-11 Member: 254249Members Posts: 6 Fully active user
Testing and streaming the new update from today and unable to calibrate the xbox 360 controller as the Left and Right Triggers are being recognized as backwards.
scifismurffrafornoBoopa

Comments

  • mortemasmortemas NYC Join Date: 2017-12-27 Member: 234625Members Posts: 9 Fully active user
    edited December 2019
    This has happened to me, too. Left trigger moves Prawn's right arm and vice versa. Also, Prawn can only go backwards when jump-jetting. Same stick works fine when walking, though. And the Prawn is all jiggly, keeps walking bit by bit on its own without touching the controller. Mine is an Xbox One controller, works fine in other games. Guess I won’t be playing Subnautica again until it’s fixed. :(
    scifismurfBoopa
  • ninjap0wzninjap0wz Join Date: 2019-12-13 Member: 256372Members Posts: 1 Fully active user
    Confirmed, using Xbox one gamepad. As a potential workaround, you can enter the settings menu and set the inputs as their reverse in the meantime while they create a patch.
    scifismurffraforno
  • scifismurfscifismurf Join Date: 2019-12-13 Member: 256379Members Posts: 1 Freshly registered user
    Mines the same, i tried to swap them manually but wont recorgnise the RT at all and the prawn does what ever the hell it wants lol
  • PrimordialPrimordial United States Join Date: 2019-12-13 Member: 256384Members Posts: 1 Fully active user
    edited December 2019
    Same issue. I downloaded a 1.8 Gb update and my controls got all bugged. Triggers are reversed and I can no longer look up or down. Tried fiddling with controls and disconnected and reconnected the controller. I am currently reinstalling the game to see if that works. I use An Xbox One controller by the way.

    Update: It did not work.
    Post edited by Primordial on
  • TurboBearTurboBear Join Date: 2019-12-16 Member: 256447Members Posts: 1 Fully active user
    edited December 2019
    Same issue here. Xbox One controller on PC. Workaround is to manually swap them in the controller configuration, but it can be confusing as the HUD will show the incorrect trigger.
    frafornoPrimordialBoopa
  • frafornofraforno Italy Join Date: 2019-12-16 Member: 256450Members Posts: 4 Fully active user
    I can confirm the issue: the triggers are reversed on xbox one controller. Re-binding them in the options solves the problem but they will be recognized as reversed (so, the game will say to press LT to swap containers, for example, when you actually have to press RT). Annoying.
    Boopa
  • BoopaBoopa United States Join Date: 2019-12-16 Member: 256466Members Posts: 1 Freshly registered user
    I came here from playing this game on my xbox one S through the 1 dollar Christmas game pass thing so I essentially played for free and loved it, then found out about Subzero so I wanted to try to help and bought the two in the bundle. It's been a long long time since I've found a game I actually enjoy so I really hope more people find out about these games and give them a chance.

    Anyways.. When I first jumped into the game I had this same issue. I'm trying to put out the fire with the extinguisher in the escape pod and the triggers are swapped it seems. By time I finally figured it out I had burned to death...… :/
  • frafornofraforno Italy Join Date: 2019-12-16 Member: 256450Members Posts: 4 Fully active user
    Any chances this will be fixed?
  • jdspaceboyjdspaceboy Join Date: 2020-01-26 Member: 257413Members Posts: 1 Freshly registered user
    Issue is still present.
  • firidanfiridan Join Date: 2020-01-26 Member: 257417Members Posts: 1 Freshly registered user
    This text was translated by google translator, I am from Russia, so I hope you understand the text.
    The problem with the gamepad. After I reconfigure the control of the gamepad in the settings, there is no longer the opportunity to get the tool from the inventory if I am inside the capsule or the built base. Moreover, if you remove the tool in the water, and then enter the base, the character will remove it from his hand automatically. Also, there is no way to get the tool from the keyboard. Problems only in new versions of build 2020. My logitech F710 gamepad.
  • thejessenobodythejessenobody Atlanta, GA, USA Join Date: 2020-01-28 Member: 257467Members Posts: 1 Fully active user
    Hey guys, created an account just to add that I believe I've found a workaround for now that works for my Xbox One Controller as this was bugging me out and I could barely play the game without frustration. Seems to solve the reversed triggers at least. Here are the steps I took as I am playing the game from the Epic Store(free giveaway).

    1. Add the game as a Non-Steam Game to your Steam Library. (You use the Subnautica.exe from your installation folder)
    2. If playing from the Epic Store you will need to add to Launch Options.
    3. Right click your Subnautica icon, go to properties and click "Set Launch Options"
    4. add "-EpicPortal" without the quotes as a launch option so that Steam knows to launch game from Epic Store.
    5. Go into Steam settings - Controller settings and make sure you have both "Xbox Configuration Support" and "Generic Gamepad Configuration Support" checked.
    6. You may or may not need to launch game from Big Picture Mode - not certain but I use that from my couch when playing.
    6. Launch game thru Steam.
    7. Enjoy!

    Please let me know if this works out for you or if the instructions need to be more clear. I can finally get back to exploring from my couch without the wonky triggers reversed. Hope this helps.

    Cheers!
  • CastunCastun US Join Date: 2020-02-06 Member: 257650Members Posts: 1 Freshly registered user
    Tried the game for the first time last night, triggers worked normally.

    Started up again tonight, and the triggers are reversed, using an XBox One wireless controller. Tested out with M&KB and the trigger buttons on the mouse are also backwards...instead of left click using the equipped item, it was right click. So not something specific to controllers, it seems.
Sign In or Register to comment.