[BUG] Crash on startup with recent (18.12.x) AMD drivers.

drbobdrbob Join Date: 2018-12-16 Member: 246031Members Posts: 13 Fully active user
edited December 2018 in Subnautica Bug Reporting
I think there has been a regression in compatibility with the latest AMD drivers. I was experiencing crashes every time I started subnautica with Radeon 18.12.x drivers.

Reverting to Radeon 18.6.1 fixed the issue for me (I haven't checked versions between 18.6.1 and the 18.12 drivers to find the exact version where things broke)

Strangely, after reverting to 18.6.1 if I then update to an 18.12.x driver (clean install) the game launches without crashing for a while, before the symptoms return and I can no longer run it without reverting to 18.6.1, just uninstalling and reinstalling the 18.12.x driver doesn't fix the issue.

I haven't established what causes it to start crashing.

I attach crash log files (also on pastebin: output_log.txt, error.txt, DxDiag.txt) I had 18.12.3 installed at the time. I am using an AMD R9 270X, connected with HDMI via a JBL SB400 soundbar to an optoma HD25e projector. I am running the epic games store version of Subnautica, version 61951-25754325-Windows.
Post edited by drbob on

Comments

  • kokovikosgkokovikosg Join Date: 2019-03-31 Member: 252070Members Posts: 3 Fully active user
    Same exact problem...
  • m_attym_atty Join Date: 2019-04-01 Member: 252084Members Posts: 2 Fully active user
    edited April 3
    Edit: Just noticed the original post date. This seems like it keeps resurfacing. Been using 19.x.x for a while now with no issues and then, out of no where, it stops working.

    Same here. Oddly, it seemed to happen out of the blue. I stopped playing for a few hours and came back (no reboots, updates or drivers updates) and starting experiencing this issue. Crashes right to desktop. The only change was I had installed additional Steam games and Steam randomly started updating installed games over and over.

    I have DDU'd and used AMD's driver cleanup utility both in safe mode as well as verifying the game files and even completely removing the game before re-installing. All to no avail.

    I will revert my drivers and give it a try. It would seem odd as I have been playing for days on the same drivers without issue. Maybe a time-bomb in the codebase?
  • TenrisTenris Join Date: 2013-03-28 Member: 184518Members Posts: 2 Fully active user
    Epic Store Version, 18.10.16 driver package version
    Crash on startup.

    I would like to add a log, but honestly, I have no idea where epic is hiding the game. even to shortcuts on the desktop load only to that garbage launcher.
  • drbobdrbob Join Date: 2018-12-16 Member: 246031Members Posts: 13 Fully active user
    edited May 7
    I had not played for a while, just tried to launch the game and the problem is back for me as well. Since my first report I've upgraded to an RX480 card, was playing with no issues on that card a couple of months ago.

    Current driver Radeon 19.4.1, same symptoms as before, I'll try reverting to 18.6.1 again to see if that helps and report back.

    output_log , error.txt, DxDiag.txt

    I am still running the epic games store version of Subnautica, version 61951-25754325-Windows.
  • drbobdrbob Join Date: 2018-12-16 Member: 246031Members Posts: 13 Fully active user
    edited May 8
    Reverting the drivers didn't work this time. Though Subnautica did run for longer after I rolled the driver back - I got a blank screen with a mouse ponter and the startup background music, instead of an immediate CTD.

    I found that deleting options.bin in
    %userprofile%\AppData\LocalLow\Unknown Worlds\Subnautica\Subnautica\SavedGames\options\
    
    fixed the crash for me.
  • GrusGrus Join Date: 2019-06-11 Member: 253321Members Posts: 2 Freshly registered user
    edited June 11
    {subzero} i have had the game crash when I start a new game and start walking up to the alien sight at the start.
Sign In or Register to comment.