Help! Mic is not working in NS2

IdlerayIdleray Join Date: 2012-10-04 Member: 161464Members, Reinforced - Shadow Posts: 154 Advanced user
Hey guys, I have a Rode Condenser Microphone connected to a Focusrite Scarlett 2i2 Audio Interface, and I switch on phantom power in order to use it.

The set up works fine in steam chat, in skype... in basically everything else. But it doesn't work in NS2.

In NS2, I've tried toggling the Input Device between Default and Focusrite USB audio, but pressing alt to speak doesn't work.

My Microphone levels at the bottom of the sound menu wiggles slightly but doesn't register my voice.

Interestingly, when I press the phantom power button on my Focusrite box (which turns the mic on or off), there's a big jump in the microphone levels, then nothing.

I'm on windows 7. I've tried device manager and the recording devices option (right clicking on the audio icon in bottom right of windows), making sure that my Focusrite is my default recording device and that everything else is disabled. Still no luck.

I really miss playing NS2 with voice comms esp when commanding, and I've googled the problem... nothing's worked yet.
Sign In or Register to comment.