Broken sound after switching rig

glutenfreeglutenfree Members Join Date: 2018-07-05 Member: 241933Posts: 18 Advanced user
edited November 2018 in Technical Support
Hello there !

After upgrading my entire PC rig, I started having a really weird sound bug specifically on NS2.

The entire audio in the game is playing fine, except for anything that is coming from my character's perspective. That includes walking/running, biting, shooting, rearming at armories and so on. The sound is either completely muted, or very distant as if I was hearing my character from far away.

I've tried to tweak the audio settings but nothing fixes it, is this something anyone ever experienced ?
Post edited by glutenfree on

Comments

  • NintendowsNintendows Members, Squad Five Blue Join Date: 2016-11-07 Member: 223716Posts: 380 Advanced user
    Make sure that you have your speaker setup set to "headphones" or "stereo". NS2 doesn't like surround sound much.
  • glutenfreeglutenfree Members Join Date: 2018-07-05 Member: 241933Posts: 18 Advanced user
    That was indeed it, surround was on by default ! Switching to stereo fixed it, thanks a lot :)
    Nintendows
  • kzoliver909kzoliver909 Members Join Date: 2021-03-17 Member: 268350Posts: 2 Freshly registered user
    If you cannot hear in-game audio (even if you still get audio for other programs), your audio output device may not be set to default. Your default device will have a green check. If there's no green check on the device you're using, right click the name of the device and set it to default.
  • kzoliver909kzoliver909 Members Join Date: 2021-03-17 Member: 268350Posts: 2 Freshly registered user
    My friend faced same issue. Then he found a solution for this.
    If you have still facing this problem and first tip doesn't help, continue to the next tip.
    1.Run the audio troubleshooter.
    2.Verify that all Windows Updates are installed.
    3.Check your cables, plugs, jacks, volume, speaker, and headphone connections.
    4.Check sound settings.
    5.Fix your audio drivers.
    6.Set your audio device as the default device
    7.Turn off audio enhancements.
Sign In or Register to comment.