Audio issue

RangDipkinRangDipkin United States Join Date: 2017-07-14 Member: 231819Members Posts: 3 Fully active user
edited November 2017 in Getting Started
Hey guys, have a minor audio problem that is preventing me from using a mic on a game that is really helpful to have one on!

I'm on windows 7, I have disabled my onboard soundcard because I use an Antelope Zen Tour, controlled by an ASIO sound driver - http://en.antelopeaudio.com/products/zen-tour/
This computer is primarily used as my recording/mixing station but since it is souped up to do that I like to game on it sometimes.

The problem is, even though windows sound recognizes the mic input (in the windows sound panel, I am getting levels), NS2 gives me an error. I am able to select the Zen Tour as a mic input in the audio menu on NS2, and the output works fine. The names of the Zen Tour inputs and outputs in NS2 are the same as they appear in windows sound panel, where they function normally. I receive this error message in console when I launch -

Error: Couldn't start recording (unsupported file or audio format)

Maybe if I knew what audio format NS2 uses I could configure the settings on my Zen Tour to match and it would work, but I don't know where to find that info. My current settings are 44.1kHz sample rate, 512 sample buffer, 24 bit depth. Any ideas? Or am I just screwed?

Thanks for any advice,
Rang

Comments

  • antouantou France Join Date: 2016-07-24 Member: 220615Members Posts: 68 Advanced user
    RangDipkin wrote: »
    My current settings are 44.1kHz sample rate, 512 sample buffer, 24 bit depth.
    Have you tried setting the bit depth to 16 ? I don't know what is supported or not, but 16 is more common than 24.

  • BeigeAlertBeigeAlert Texas Join Date: 2013-08-08 Member: 186657Members, Super Administrators, Forum Admins, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, NS2 Map Tester, Reinforced - Diamond, Reinforced - Shadow, Subnautica Playtester, Pistachionauts Posts: 2,818 admin
    antou wrote: »
    RangDipkin wrote: »
    My current settings are 44.1kHz sample rate, 512 sample buffer, 24 bit depth.
    Have you tried setting the bit depth to 16 ? I don't know what is supported or not, but 16 is more common than 24.

    That was my first thought too.
  • RangDipkinRangDipkin United States Join Date: 2017-07-14 Member: 231819Members Posts: 3 Fully active user
    Oh, it looks like I misspoke. I am at 44.1/16 actually
Sign In or Register to comment.