OHMAGAWD! PDA now openable while inside the Seamoth

RainstormRainstorm Montreal (Quebec) Join Date: 2015-12-15 Member: 210003Members
After reaching the abandoned base in the jellyshroom cave i mistakingly tried to bring up the PDA while comfortably seated in my trusty seamoth, figured i'd try it even tho i was sure it still wouldnt work (silly,silly meh) but OMFGWTFIZDAT! It worked! /faints :flushed:


That moment when you realize something you've wished for so long is nao realllll !


  • DaveyNYDaveyNY Schenectady, NY Join Date: 2016-08-30 Member: 221903Members
    edited December 2016
    Yeah, that was noticed and posted about almost month ago.
    Ain't it great how the little things make us go all wonky over this game.
  • RainstormRainstorm Montreal (Quebec) Join Date: 2015-12-15 Member: 210003Members
    Indeed! i took a small break from the game so this feature is new to me. Its Xmas early this year for me :smiley:
  • mndfreezemndfreeze Grand Tempe Reef Join Date: 2016-02-26 Member: 213456Members
    I just switched to experimental after a good 9 month break from the game and found this yesterday when getting in my very first prawn suit. Actually hit tab out of habit not even realizing until it popped up the magnatude of what just occured. It took me a minute then I exploded into happiness and fell apart into a pile of rainbows.

    Its pretty rad.
Sign In or Register to comment.