Can't connect to own NS2 Server

SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
Hey guys,
I am new here and here and did not find the exact problem/solution in this forum, so I start my own "Discussion"

I got a root Server at "1und1" (ISP in Germany), running the last Ubuntu Version.
Since my Website almost doesn't cause any traffic or cpu-time I wanted to install an NS2 Server for this phantastic game.

I used this how2: http://wiki.unknownworlds.com/ns2/Dedicated_Server#Ubuntu

And everything went good.
Server is up and running, BUT if I connect client says: "waiting for server" resulting in a connection time-out several minutes later.


I opened up 27015 and 27016 with "iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport poooortnumber -j ACCEPT"

:/etc/iptables# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT udp -- anywhere anywhere udp dpt:27015
ACCEPT udp -- anywhere anywhere udp dpt:27016
ACCEPT tcp -- anywhere anywhere tcp dpt:27016
ACCEPT tcp -- anywhere anywhere tcp dpt:27015

Still just "waiting for server" if I want to connect to "SEK200 Fan" Server.

Did I do something wrong? I don't get any error or something.
«1

Comments

  • woozawooza Switzerland Join Date: 2013-11-21 Member: 189496Members, Squad Five Blue Posts: 171 Fully active user
    What does your startup line contain?

    btw. you can close TCP if you dont work with Webadmin
    Mattk50 wrote: »
    Quoting this again to remind people what a bad development and community interaction policy looks like. Lets go down the list. See if you can find exactly where each point is hit.
    -Contradicts community feedback by vaguely insisting a bad change has been "positive"
    -Decrees that the change is permanent despite overwhelming community outcry in the negative
    -Misrepresent the arguments people are using in order to get an easy position to defend your change from.
    -Fail to make any real arguments in favor of your position other than the aforementioned "its positive"
    -Claim to understand complaints immediately after failing to properly interpret and respond to a quote in the same post.
    -Claim that holes left by the newly missing experiences are being filled by unrelated and half baked mechanics.
    -Ignoring community feedback, then retroactively pretending that changes made personally were based on community feedback.

    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    edited August 2015
    This:
    !/bin/bash
    # Natural Selection 2
    # Server Management Script
    # Author: Daniel Gibbs
    # Website: http://gameservermanagers.com
    version="040715"

    #### Variables ####

    # Notification Email
    # (on|off)
    emailnotification="on"
    email="..."

    # Steam login
    steamuser="..."
    steampass="..."

    # Start Variables
    defaultmap="ns2_summit"
    port="27016"
    maxplayers="24"
    ip="212.227.250.60"
    updateonstart="yes"
    servername="SEK2000 Fans"
    webadminuser="admin"
    webadminpass="..."
    webadminport="8080"
    configpath="server1"
    modstorage="server1/Workshop"
    mods=""
    password=""
    # Add the following line to the parms if you want a private server. Ensuring
    # that the password variable above is not left empty.
    # -password \"${password}\"

    # http://wiki.unknownworlds.com/ns2/Dedicated_Server
    fn_parms(){
    parms="-name \"${servername}\" -port ${port} -webadmin -webdomain ${ip} -webuser ${webadminuser} -webpassword \"${webadminpass}\" -webport ${webadminport} -map ${defaultmap} -limit ${maxplayers} -config_path \"${rootdir}/${configpath}\" -modstorage \"${rootdir}/${modstorage}\" -mods \"${mods}\""
    }

    #### Advanced Variables ####

    # Steam
    appid="4940"

    # Server Details
    servicename="ns2-server"
    gamename="Natural Selection 2"
    engine="spark"

    # Directories
    rootdir="$(cd "$(dirname "${BASH_SOURCE[0]}")" && pwd)"
    selfname="$(basename $0)"
    lockselfname=".${servicename}.lock"
    filesdir="${rootdir}/serverfiles"
    systemdir="${filesdir}"
    executabledir="${filesdir}"
    executable="./server_linux32"
    backupdir="${rootdir}/backups"
    Post edited by SEK2000_Fan on
  • woozawooza Switzerland Join Date: 2013-11-21 Member: 189496Members, Squad Five Blue Posts: 171 Fully active user
    port="27016"

    I dont know how to config the ns2 server on linux but shoulnd't this port represent the game port instead of the query port?

    Also can you verify that the server has loaded the map? I had the "Wait for server" error once too. Caused by a mod that was no longer available on the workshop but server still tried to download the mod from steam.

    Mattk50 wrote: »
    Quoting this again to remind people what a bad development and community interaction policy looks like. Lets go down the list. See if you can find exactly where each point is hit.
    -Contradicts community feedback by vaguely insisting a bad change has been "positive"
    -Decrees that the change is permanent despite overwhelming community outcry in the negative
    -Misrepresent the arguments people are using in order to get an easy position to defend your change from.
    -Fail to make any real arguments in favor of your position other than the aforementioned "its positive"
    -Claim to understand complaints immediately after failing to properly interpret and respond to a quote in the same post.
    -Claim that holes left by the newly missing experiences are being filled by unrelated and half baked mechanics.
    -Ignoring community feedback, then retroactively pretending that changes made personally were based on community feedback.

    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    changed the port to 27015
    still "waiting for server"

    on the shell it still got no error
    ./ns2server start
    [ OK ] Update ns2-server: Checking for update: SteamCMD

    No update available:
    Current version: 713077
    Available version: 713077
    https://steamdb.info/app/4940/

    [ OK ] Update ns2-server: No update available
    [ OK ] Starting ns2-server: SEK2000 Fans
  • woozawooza Switzerland Join Date: 2013-11-21 Member: 189496Members, Squad Five Blue Posts: 171 Fully active user
    hm what happens if you remove the line:
    ip="212.227.250.60"


    Mattk50 wrote: »
    Quoting this again to remind people what a bad development and community interaction policy looks like. Lets go down the list. See if you can find exactly where each point is hit.
    -Contradicts community feedback by vaguely insisting a bad change has been "positive"
    -Decrees that the change is permanent despite overwhelming community outcry in the negative
    -Misrepresent the arguments people are using in order to get an easy position to defend your change from.
    -Fail to make any real arguments in favor of your position other than the aforementioned "its positive"
    -Claim to understand complaints immediately after failing to properly interpret and respond to a quote in the same post.
    -Claim that holes left by the newly missing experiences are being filled by unrelated and half baked mechanics.
    -Ignoring community feedback, then retroactively pretending that changes made personally were based on community feedback.

    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    sadly: still waiting on server
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    edited August 2015
    @SEK2000_Fan : Have a look at the console with ./ns2server console . You also might want to add -logdir \"${rootdir}/${configpath}\" to your parms field so the logs get saved into your config folder instead of ~/.config/Natural Selection 2/
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    Press Tab to open the console window
    Press Ctrl-C to exit
    Build 275
    Ubuntu x86_64
    Server tickrate 30, client sendrate 20, bandwidth limit per player 25600
    [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
    Setting breakpad minidump AppID = 4920
    Connected to Steam servers
    Web server running at 212.227.250.60:8080
    [ 2.043] Worker 03 : Error: Unable to open 'game_setup.xml' (usage 0x1)
    [ 2.043] Worker 03 : Error: Unable to load 'game_setup.xml'!
    VAC Enabled
    Client connecting (87.152.36.171)
    Client disconnected (87.152.36.171) Quit
    [69820.489] Unbound/Unknown : Error: Web error [400]
    [69820.581] Unbound/Unknown : Error: Web error [400]
    Client connecting (90.17.196.58)
    Client disconnected (90.17.196.58) Quit
    Client connecting (91.188.37.123)
    Client connecting (93.47.218.131)
    Client disconnected (91.188.37.123) Timeout
    Client disconnected (93.47.218.131) Quit
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    [ 2.043] Worker 03 : Error: Unable to open 'game_setup.xml' (usage 0x1)
    [ 2.043] Worker 03 : Error: Unable to load 'game_setup.xml'!

    That's your deal-breaker. It seems like the server binary is not able to find the game logic scripts. Use ./ns2server validate to make sure your game files are not corrupted.
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    i validated...
    still same errors....
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    edited August 2015
    i validated...
    still same errors....

    Do you start the ns2 server from inside the ns2server folder?
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    yes

    what's inside the serverfiles folder.
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    edited August 2015
    Edit:
    Wait...
    the Serverfiles Folder...

    [email protected]:~/serverfiles$ ls
    D3DX9_43.dll fmod_event.dll libtbb.so
    Dedicated_Server_Usage.txt fmod_event_net.dll libtbb.so.2
    Editor Manual.pdf fmodex.dll libtier0_s.so
    GLSLCompiler libGLEW.so.1.9 libvstdlib_s.so
    HashBuilder libSpark_Cinematic.so lua51.dll
    Microsoft.VC80.CRT.manifest libSpark_Client.a msvcm80.dll
    PhysX3Common_x86.dll libSpark_Core.so msvcp80.dll
    PhysX3Common_x86.pdb libSpark_Network.so msvcr80.dll
    PhysX3Cooking_x86.dll libSpark_Physics.so ns2
    PhysX3Cooking_x86.pdb libSpark_Render.so ns2_linux32
    PhysX3Gpu_x86.dll libSpark_Server.a server_linux32
    PhysX3_x86.dll libSpark_Sound.so steam-runtime
    PhysX3_x86.pdb libawesomium-1-7.so.4 steam_api.dll
    RenderTest libcurl.dll steam_appid.txt
    Server.exe libfmodevent-4.44.16.so steamapps
    Spark_Core.dll libfmodevent.so steamclient.dll
    Spark_Network.dll libfmodeventnet-4.44.16.so steamclient.so
    Spark_Physics.dll libfmodeventnet.so system
    Steam.dll libfmodex-4.44.16.so tbb.dll
    SteamAPIUpdater.dll libfmodex.so tier0_s.dll
    Update.dll liblua51.so tutorial
    builder_setup.xml libmongoose.so utils
    cacert.pem libsdkencryptedappticket.so vstdlib_s.dll
    core libsteam.so
    explore libsteam_api.so
    Post edited by SEK2000_Fan on
  • NomadThanatosNomadThanatos Wuhan Join Date: 2015-08-06 Member: 206835Members Posts: 10 Fully active user
    edited August 2015
    I have the same problem.

    Also I use Daniel Gibbs's script.

    After build 275, you can not connect to your server.

    And the web admin tells you that server is loading.

    I think "[ 2.043] Worker 03 : Error: Unable to open 'game_setup.xml' (usage 0x1)" leads to this problem.

    But I wonder why is unable to "open".

    Even if you just download server files using Daniel Gibbs's script and run the server by original command. Also I validate the server files.

    I think Daniel Gibbs's script is great convenient to maintain the server, and I do not know where I can get more detail logs why unable to open that xml.

    I posted at here: http://forums.unknownworlds.com/discussion/136479/unable-to-load-game-setup-xml
  • NomadThanatosNomadThanatos Wuhan Join Date: 2015-08-06 Member: 206835Members Posts: 10 Fully active user
    It's not a problem about your firewall's setting.
    You can see steam connection log which shows that you have connected.
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    Okay add -verbose to your parms and see what the log says after a restart.
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    thx guys for the support.
    well i tried the -verbose command, here is the log:
    [email protected]:~$ vi /home/ns2server/log/console/ns2-server-console-23-08-2015-09-22-10.log
    Server tickrate 30, client sendrate 20, bandwidth limit per player 25600
    [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
    Setting breakpad minidump AppID = 4920
    Connected to Steam servers
    Web server running at 212.227.250.60:8080
    [ 1.189] Worker 02 : Error: Unable to open 'game_setup.xml' (usage 0x1)
    [ 1.189] Worker 02 : Error: Unable to load 'game_setup.xml'!
    VAC Enabled
    Client connecting (84.59.76.27)
    Client connecting (87.185.110.47)
    Client disconnected (87.185.110.47) Quit
    Client disconnected (84.59.76.27) Quit
    [63504.989] Unbound/Unknown : Error: Web error [400]
    Disconnected from Steam servers
    Connected to Steam servers
    VAC Enabled
    [122211.917] Unbound/Unknown : Error: Web error [400]
    [130863.595] Unbound/Unknown : Error: Web error [400]
    Client connecting (185.22.143.181)
    Client disconnected (185.22.143.181) Quit
    [206900.068] Unbound/Unknown : Error: Web error [400]
    [280959.026] Unbound/Unknown : Error: Web error [400]
    [298803.351] Unbound/Unknown : Error: Web error [400]
    [327357.469] Unbound/Unknown : Error: Web error [400]
    Client connecting (86.42.55.195)
    Client disconnected (86.42.55.195) Quit
    [364184.653] Unbound/Unknown : Error: Web error [400]
    [383377.414] Unbound/Unknown : Error: Web error [400]
    ~
    ~
    ~
    ~
    ~
    ~
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    edited August 2015
    thx guys for the support.
    well i tried the -verbose command, here is the log:
    [email protected]:~$ vi /home/ns2server/log/console/ns2-server-console-23-08-2015-09-22-10.log
    Server tickrate 30, client sendrate 20, bandwidth limit per player 25600
    [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
    Setting breakpad minidump AppID = 4920
    Connected to Steam servers
    Web server running at 212.227.250.60:8080
    [ 1.189] Worker 02 : Error: Unable to open 'game_setup.xml' (usage 0x1)
    [ 1.189] Worker 02 : Error: Unable to load 'game_setup.xml'!
    VAC Enabled
    Client connecting (84.59.76.27)
    Client connecting (87.185.110.47)
    Client disconnected (87.185.110.47) Quit
    Client disconnected (84.59.76.27) Quit
    [63504.989] Unbound/Unknown : Error: Web error [400]
    Disconnected from Steam servers
    Connected to Steam servers
    VAC Enabled
    [122211.917] Unbound/Unknown : Error: Web error [400]
    [130863.595] Unbound/Unknown : Error: Web error [400]
    Client connecting (185.22.143.181)
    Client disconnected (185.22.143.181) Quit
    [206900.068] Unbound/Unknown : Error: Web error [400]
    [280959.026] Unbound/Unknown : Error: Web error [400]
    [298803.351] Unbound/Unknown : Error: Web error [400]
    [327357.469] Unbound/Unknown : Error: Web error [400]
    Client connecting (86.42.55.195)
    Client disconnected (86.42.55.195) Quit
    [364184.653] Unbound/Unknown : Error: Web error [400]
    [383377.414] Unbound/Unknown : Error: Web error [400]
    ~
    ~
    ~
    ~
    ~
    ~

    That doesn't really look like a verbose log. Try to run server_linux32 directly with -verbose from inside the serverfiles folder just to test if it's an issue with ns2 or with the management script.
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    like this:
    [email protected]:~/serverfiles$ ./server_linux32 -verbose
    GetInstanceCount currently unimplemented
    [ 0.000] Main : Filesystem initialized, cache enabled
    Press Tab to open the console window
    Press Ctrl-C to exit
    Build 275
    Ubuntu x86_64
    [ 0.000] Main : FSCache: Caching '/home/ns2server/serverfiles/system/' took 0.000s, cacheSize 0
    [ 0.061] Main : Loaded 14846 precomputed hashes from /home/ns2server/serverfiles/ns2/.hashes
    [ 0.073] Main : FSCache: Caching '/home/ns2server/serverfiles/ns2/' took 0.011s, cacheSize 0
    [ 0.074] Main : Loaded 199 precomputed hashes from /home/ns2server/serverfiles/core/.hashes
    [ 0.074] Main : FSCache: Caching '/home/ns2server/serverfiles/core/' took 0.000s, cacheSize 0
    Server tickrate 30, client sendrate 20, bandwidth limit per player 25600
    [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
    Setting breakpad minidump AppID = 4920
    Connected to Steam servers
    [ 0.788] Main : Add Query class:Entity, total grids 1
    [ 0.840] Worker 03 : Error: Unable to open 'game_setup.xml' (usage 0x1)
    [ 0.841] Worker 03 : Error: Unable to load 'game_setup.xml'!
    [ 0.841] Main : World failed to load map ''
    VAC Enabled
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    edited August 2015
    like this:
    [email protected]:~/serverfiles$ ./server_linux32 -verbose
    GetInstanceCount currently unimplemented
    [ 0.000] Main : Filesystem initialized, cache enabled
    Press Tab to open the console window
    Press Ctrl-C to exit
    Build 275
    Ubuntu x86_64
    [ 0.000] Main : FSCache: Caching '/home/ns2server/serverfiles/system/' took 0.000s, cacheSize 0
    [ 0.061] Main : Loaded 14846 precomputed hashes from /home/ns2server/serverfiles/ns2/.hashes
    [ 0.073] Main : FSCache: Caching '/home/ns2server/serverfiles/ns2/' took 0.011s, cacheSize 0
    [ 0.074] Main : Loaded 199 precomputed hashes from /home/ns2server/serverfiles/core/.hashes
    [ 0.074] Main : FSCache: Caching '/home/ns2server/serverfiles/core/' took 0.000s, cacheSize 0
    Server tickrate 30, client sendrate 20, bandwidth limit per player 25600
    [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
    Setting breakpad minidump AppID = 4920
    Connected to Steam servers
    [ 0.788] Main : Add Query class:Entity, total grids 1
    [ 0.840] Worker 03 : Error: Unable to open 'game_setup.xml' (usage 0x1)
    [ 0.841] Worker 03 : Error: Unable to load 'game_setup.xml'!
    [ 0.841] Main : World failed to load map ''
    VAC Enabled

    Edit: Damn it's too early. Okay seems like something is off with the FileSystemCache under Linux will dig into it.
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
    SEK2000_Fan
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    that would be awesome, thx
  • matsomatso Master of Patches Join Date: 2002-11-05 Member: 7000Members, Forum Moderators, NS2 Developer, Constellation, NS2 Playtester, Squad Five Blue, Squad Five Silver, Squad Five Gold, Reinforced - Shadow, NS2 Community Developer Posts: 1,554 mod
    The game_setup.xml file it is looking for should be the one in the ns2 directory (ie a path like ".../steamapps/commons/Natural Selection 2 Dedicated Server/ns2/game_setup.xml").

    If that file is present, the only thing I can think of that would cause that error is if you are using the "-game" option on the commandline ... which sounds weird.
    Member of CDT, Senior Spark Engine Hacker
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    @SEK2000_Fan Just to verify /serverfiles/ns2/ contains the game_setup.xml, right?
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    game_setup.xml is in /serverfiles/ns2 along with
    cinematics game_setup.xml gamestrings lua maps materials models seasonal shaders sound web
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    edited August 2015
    @SEK2000_Fan While we investigate into this issue internally there is one last thing you could try:
    1. Make sure the steam login you use owns ns2
    2. Change the appid to 4920
    3. run ./ns2server validate
    4. See if that changes anything

    Also what version of Ubuntu are you using?
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
  • NoMNoM Join Date: 2015-04-13 Member: 203407Members, NS2 Playtester Posts: 39 Fully active user
    edited August 2015
    SEK2000_Fan could you please verify your permissions are correct by running these lines:
    cd /home/ns2server
    sudo chown -R ns2server:ns2server serverfiles
    

    We've had no problems on 15.04, also by default traffic should be allowed unless you've written a rule to drop all traffic prior to the ones you've disclosed.

    To flush ip tables, simply run:
    sudo iptables -F
    

    Other than that, you could try upgrade the distro? Although I'm pretty sure people have run a server using that version in the past.
    GhoulofGSG9
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    my linux ver is

    [email protected]7194895:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 12.04.5 LTS
    Release: 12.04
    Codename: precise
  • SEK2000_FanSEK2000_Fan Germany Join Date: 2015-08-13 Member: 207106Members Posts: 18 Fully active user
    also, if i change the app id from 4940 to 4920 it states:

    [email protected]:~$ ./ns2server start
    [ OK ] Update ns2-server: Checking for update: Server logs: No update requested/home/ns2server/functions/fn_update_check: line 56: [: : integer expression expected
    [ INFO ] Update ns2-server: Forcing update to correct issue
    loading fn_update_dl...OK
    [ OK ] Update ns2-server: Updating SEK2000 Fans
    Redirecting stderr to '/home/ns2server/Steam/logs/stderr.txt'
    [ 0%] Checking for available updates...
    Verifying installation...
    Steam Console Client (c) Valve Corporation
    -- type 'quit' to exit --
    Loading Steam API...OK.

    Logging in user 'xxxaver1' to Steam Public...Logged in OK
    Waiting for license info...OK
    ERROR! Failed to install app '4920' (No subscription)
    [ OK ] Update ns2-server: Updating SEK2000 Fans
    Redirecting stderr to '/home/ns2server/Steam/logs/stderr.txt'
    [ 0%] Checking for available updates...
    Verifying installation...
    Steam Console Client (c) Valve Corporation
    -- type 'quit' to exit --
    Loading Steam API...OK.

    Logging in user 'xxxaver1' to Steam Public...Logged in OK
    Waiting for license info...OK
    ERROR! Failed to install app '4920' (No subscription)
    [ .... ] Update ns2-server: Checking for update: SteamCMDgrep: : No such file or directory
    [ FAIL ] Update ns2-server: Checking for update: SteamCMD: Not returning version [email protected]:~$
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    also, if i change the app id from 4940 to 4920 it states:

    [email protected]:~$ ./ns2server start
    [ OK ] Update ns2-server: Checking for update: Server logs: No update requested/home/ns2server/functions/fn_update_check: line 56: [: : integer expression expected
    [ INFO ] Update ns2-server: Forcing update to correct issue
    loading fn_update_dl...OK
    [ OK ] Update ns2-server: Updating SEK2000 Fans
    Redirecting stderr to '/home/ns2server/Steam/logs/stderr.txt'
    [ 0%] Checking for available updates...
    Verifying installation...
    Steam Console Client (c) Valve Corporation
    -- type 'quit' to exit --
    Loading Steam API...OK.

    Logging in user 'xxxaver1' to Steam Public...Logged in OK
    Waiting for license info...OK
    ERROR! Failed to install app '4920' (No subscription)
    [ OK ] Update ns2-server: Updating SEK2000 Fans
    Redirecting stderr to '/home/ns2server/Steam/logs/stderr.txt'
    [ 0%] Checking for available updates...
    Verifying installation...
    Steam Console Client (c) Valve Corporation
    -- type 'quit' to exit --
    Loading Steam API...OK.

    Logging in user 'xxxaver1' to Steam Public...Logged in OK
    Waiting for license info...OK
    ERROR! Failed to install app '4920' (No subscription)
    [ .... ] Update ns2-server: Checking for update: SteamCMDgrep: : No such file or directory
    [ FAIL ] Update ns2-server: Checking for update: SteamCMD: Not returning version [email protected]:~$

    Yeah you can't use 4920 if the used steam account doesn't own ns2 ;) The very reason 4940 exists.
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
Sign In or Register to comment.