Problem while edit boot.ini WindowXPSP3

Goliath VietnamGoliath Vietnam Join Date: 2013-01-07 Member: 178080Members
edited September 2013 in Technical Support
Hi , i have follow the thread about 32bit crash , while im editing my boot.ini , my executable line is difference like this
[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
c:\hiren.bin="Hiren's Boot HDD v10.4"

How should i add "3GB' line ? before or after /noexecute=optin ? :D Please edit this for me :))


  • MB42MB42 Join Date: 2013-09-07 Member: 187923Members
    edited September 2013
    I don't think that it matters where you place the "/3gb" parameter within the line.
    So this should work -
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional 3Gb" /3Gb /noexecute=optin /fastdetect

    Remember to make a copy of the boot entry so that you have two lines, one with the 3gb switch and one with out it.
    Note that the line I made above has "...Professional 3Gb" entered as the title. This way when you boot you will know which boot option to choose from.

    PS - My computer was somewhat unstable with this switch. My video card didn't appear to like it so much and NS2 crashed on startup. I had to remove it.
  • DC_DarklingDC_Darkling Join Date: 2003-07-10 Member: 18068Members, Constellation, Squad Five Blue, Squad Five Silver
    * it doesnt matter if its before or after another parameter.
    * 'its 4GB in total, INCLUDING your vidcard.' "but my vidcard uses 1GB of memory.." 'Gratz, you now have 3GB left, that includes your windows :D'.
    * If you feel like you will screwup the boot.ini, copy the file first and name it something like boot2.ini. IF you screw it up, winxp should still boot in safe mode with F8. (or any rescue disk or boot disk which can read ntfs) Then simply replace the broken file by your copied one.
Sign In or Register to comment.