Menu Trouble

AsuterisukuAsuterisuku Join Date: 2010-05-30 Member: 71899Members, Reinforced - Shadow Posts: 3
I know you guys probably aren't working on this game so much any more, what with NS 2 picking up steam, *ba-dum-psh* but the Linux update for Half-Life seems to have broken a crucial part of this mod: The evolution/requisitions menu for Kharaa and Marines.

Here's the problem I'm having. Whenever I move the mouse however far from the center of the screen - usually two selections away - the mouse reverts to the center of the screen. The radius is close enough to be completely unable to select anything from the menu, essentially rendering the game difficult for marines, and unplayable for Kharaa.

I'll admit, this has been tested only in Fullscreen mode in various resolutions. I'll get back to you when I have a test from windowed mode.
In a world beyond controlling,
Are you going to deny the saviour in front of your eyes?

Comments

  • AsuterisukuAsuterisuku Join Date: 2010-05-30 Member: 71899Members, Reinforced - Shadow Posts: 3
    Window has now been tested, as have various other options. Turning on Raw Mouse Input seemed to help, but when I did, the mouse would fly to the absolute bottom of the screen whenever I let go of the right mouse button, and not come back until I hit esc twice, shifting the focus of the game away from the battlefield and back to it. Believe me when I say that this is not a solution.
    In a world beyond controlling,
    Are you going to deny the saviour in front of your eyes?
  • GiGaBiTeGiGaBiTe Join Date: 2003-10-07 Member: 21489Members Posts: 1,116 Advanced user
    I think the only thing you're going to be able to do is bind keys to the menu items that aren't clickable (Hive, RT, Defense upgrade, Focus upgrade, upper life forms.) Valve seems intent on killing all vestiges of the HL engine with all of the terrible updates they've done to it.

    Rumor has it that the NS source code was lost, in which case would mean only Valve could fix the problem (unlikely to happen) since no new NS builds could be made.
    QUOTE (unknown)
    Admiral, why dont we just breach the hull after overriding the automatic hatchlocks closing procedure?

    Last time we did this an onos just put its fat **** inside the hole and lerks just farted a new athmosphere.
    It looked so gross that we decided to never ever do this again.


    My Website
    NS Map Archive
  • tschumanntschumann Australia Join Date: 2010-05-26 Member: 71862Members Posts: 242 Advanced user
    Have you tried again recently? I think there was an update in the last few weeks that fixed a mouse issue for mods.
  • RegnarebRegnareb Join Date: 2007-08-26 Member: 62008Members, NS2 Playtester Posts: 424 Advanced user
    Have you tried to reinstall it? I had problems with NS back in the day, and usually a reinstall always fixed the problems.

    I don't have your problem personally and never saw it.
    In NS1, no matter which class you are, you can feel really powerful and a threat to anyone, while being greatly threatened by anyone at the same time.
    In NS2, you just feel crappy against nearly everything, but at the same time, you feel as much crappy when the roles are reversed.

    This is what fun is about, feeling as an asset to the game, and feeling that you can change something.
  • AsuterisukuAsuterisuku Join Date: 2010-05-30 Member: 71899Members, Reinforced - Shadow Posts: 3
    Well that's interesting. Yesterday's update to Half-Life finally fixed the problem. Wow. That game's still getting updated after fifteen years. O.o
    In a world beyond controlling,
    Are you going to deny the saviour in front of your eyes?
Sign In or Register to comment.