Bad Server Message - Killing NS1 Servers

waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
Help!!
For weeks people have been getting dropped from servers due to

Parse server: Bad Server message: Client ###

What causes this, ive seen entire servers get emptied because of this error.

Can anyone help?

[email protected]

This seems to be a client based error, but it hits ALOT of people playing NS1 on most servers, not all.

Comments

  • tschumanntschumann Australia Join Date: 2010-05-26 Member: 71862Members Posts: 242 Advanced user
    Are the affected servers all with the same host?
    Any other error messages? Does it happen randomly?
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    edited October 2012
    The effected servers are not all the same host, Currently their are 2 safe servers to play on.

    WongaNS
    EvolveNS

    these 2 you can play on , every other server we tested all have the same issue, some more then others.

    It seems to go in waves, ever 2 hours, ever 30min , depending on the day it will boot half the server, we thought it may be some kind of Dos attack on a particular server but it cant be cause multiple people get booted on other hosts.

    Its all the same error message.

    Its extremely confusing, and i do not know enough about steam and hl1 severs.

    Currently - the top 2 servers on this list - http://www.gametracker.com/search/hlns/ (surprise)





    Another post on the same issue.

    I recently started an NS1 server in the US and for the past 2 weeks we have been getting an irregular but constant error. The errors disconnect clients with svc_bad type errors with or without amx and metamod enabled. The errors appear to come in waves, so when one person get disconnected others begin to disconnect too and then it happens all over again a few minutes later. There have been times when we can go for hours though and no one gets kicked (but these are rare). This occurs on all of our servers (3 different hosts). We also noticed it occurring on random servers we would join. It does not seem to occur as often on your server (we haven't fully tested this). Some clients (such as myself) do not ever get the error or do so very rarely. Also, the errors occur irregardless of the player count. Some of the errors are given below. Any help you might be able to provide would be much appreciated. We are trying to keep NS1 going and even growing, but these errors are making it difficult.

    Host_Error: UserMsg: Not Present on Client 247 <-- that number changes


    Host_Error: DispatchUserMsg: User Msg BlipList/101 sent too much data (197 bytes), 192 bytes max


    Host_Error: CL_ParseServerMessage: Bad Server Message


    Host_Error: CL_EntityNum: 1426 is an invalid number, cl.max_edicts is 133


    Unable to load voice codec DLL uF?":?O%*
    Cw(?U`{?B2eMO`3T?f`?? =[?2.]?%e??vv??$"??g$G?t`??!vS?5"D?"??B&zBs.??d}?F26K?d9TTbk?? =_?6.]F 5??w"??$#?DbsA?tb?T%uTU6"B?"i??$z?Ds(?U`)?C35L?`4U?b>?S$h]?1{^N&5??t%??&r??g"FPt2?W#!UU0qAR">?? ,?Fp*?.dll. Voice disabled.
    Host_Error: CL_ParseServerMessage: Bad server message


    103304 0018 svc_newusermsg
    BAD: 243:svc_bad
    Wrote erroneous message to buffer.dat
    Host_Error: CL_ParseServerMessage: Bad server mes


    Sent at 9:25 AM on Thursday

    Post edited by Unknown User on
  • xDragonxDragon Join Date: 2012-04-04 Member: 149948Members, NS2 Playtester, Squad Five Gold, NS2 Map Tester, Reinforced - Shadow Posts: 1,954 Fully active user
    Happens to all ~28+ player NS1 servers, or atleast ones running AMX/Metamod and their fair share of plugins. People have put tons of time and effort into reducing the occurance of those issues, mainly by making improvements to AMXMod and its plugins, but it mainly stems from so many systems built onto of oneanother, each with their own set of bugs. Judging by the message posted your probably talking mainly about the new NA NS1 server, and the owner of that server knows who can help.
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    We have tested servers without plugins, just pure clean, and the errors still happen.
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    QUOTE (xDragon @ Oct 11 2012, 10:34 AM) »
    Happens to all ~28+ player NS1 servers, or atleast ones running AMX/Metamod and their fair share of plugins. People have put tons of time and effort into reducing the occurance of those issues, mainly by making improvements to AMXMod and its plugins, but it mainly stems from so many systems built onto of oneanother, each with their own set of bugs. Judging by the message posted your probably talking mainly about the new NA NS1 server, and the owner of that server knows who can help.



    Are you saying its directly related to how steam and ns1 servers are working right now? Its wierd that it at one time was working, but now its not. Sad
  • xDragonxDragon Join Date: 2012-04-04 Member: 149948Members, NS2 Playtester, Squad Five Gold, NS2 Map Tester, Reinforced - Shadow Posts: 1,954 Fully active user
    Its a bug in NS1/HL that gets exacerbated by larger playercounts and plugins. When valve adapted GLSRC to the steam platform it seems to have had a negative impact on the engine, as afterwards it never ran quite as smoothly or as reliably.
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    QUOTE (xDragon @ Oct 11 2012, 11:16 AM) »
    Its a bug in NS1/HL that gets exacerbated by larger playercounts and plugins. When valve adapted GLSRC to the steam platform it seems to have had a negative impact on the engine, as afterwards it never ran quite as smoothly or as reliably.



    I was starting to think that is was the engine itself, it has to be, servers without pluggins crashing people ect...

    Thats very unfortunate , so other then asking the "2" servers that have put the time into fixing it, their is nothing we can do about it.
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    Does anyone know how or who to talk to about these issues? Flayra mabey one of your team can look into keeping NS1 alive? :D
  • That_Annoying_KidThat_Annoying_Kid Sire of Titles Join Date: 2003-03-01 Member: 14175Members, Constellation Posts: 5,581 Fully active user
    Hi [email protected]


    perhaps this thread (which seems to detail the very issues discussed here) can shed some light on the matter

    http://www.evolvens.com/forums/viewtopic.php?id=2386


    I'm glad that you enjoy ns! Certainly no other game plays like it, especially when you get a game that hits on all cylinders
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    edited October 2012
  • That_Annoying_KidThat_Annoying_Kid Sire of Titles Join Date: 2003-03-01 Member: 14175Members, Constellation Posts: 5,581 Fully active user
    ns4life. I'm just saddened you missed the heyday waflz ¬_¬


    Garterman and Asmo talked about stability, I'm pretty sure that is why Wonga is stable.

    Like Aga said Asmo has pretty much looked over every line of code, and short of doing that (on all layers) it's a vexing issue that isn't likely to see much time from the NS dev team
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    I think they dont really want to work on it right now, and would sooner get NS2 up and running smoothly.

    I use to play in 2003, tons of games, admin on voogru servers, We had a huge community, an awesome community.

    The servers were fine then!
  • xDragonxDragon Join Date: 2012-04-04 Member: 149948Members, NS2 Playtester, Squad Five Gold, NS2 Map Tester, Reinforced - Shadow Posts: 1,954 Fully active user
    I dont think that even if they wanted to patch NS1 at this point they could, from the sound of it some of the NS1 source code has been lost.

    But as already said Asmo would be the guy to talk to, he put in alot of effort to get it running as smoothly as possible.
  • tschumanntschumann Australia Join Date: 2010-05-26 Member: 71862Members Posts: 242 Advanced user
    I would have said this probably has to do with plugins too.

    Has this only started happening recently?
    Have you or anyone else tried contacting the people who run the working servers to see what plugins they're using?

    I doubt the Natural Selection source code is lost though.
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    Because the 2 servers are in "drama feud" I dont think Asmode would want to help the other one. Its pretty stupid.
  • tschumanntschumann Australia Join Date: 2010-05-26 Member: 71862Members Posts: 242 Advanced user
    That's unfortunate.

    How long has the problem been around?
  • That_Annoying_KidThat_Annoying_Kid Sire of Titles Join Date: 2003-03-01 Member: 14175Members, Constellation Posts: 5,581 Fully active user
    as in Voogru Server? with his uber awesome plugin?

    Around that time I was on [who]Thems modified NS and the lunixmonster
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    Yesir, Voogru servers :D. Voog was amazing at fixing and running plugins.

    I prolly played with you at one point , -IA- was the tag Insane Aggression was the guild.




    The issues have been consistent for about a month.
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    It pisses me off that by updating the platform causes issues for the MOD, it forces the NS team to continue to update their game to make it runnable.
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    Team?

    Guess its just GG to Ns1 haha, farewell!
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    Pretty funny, So because i posted asking about help for one of the servers, i got banned from one of the "2" Fued servers. tooo funny.
  • That_Annoying_KidThat_Annoying_Kid Sire of Titles Join Date: 2003-03-01 Member: 14175Members, Constellation Posts: 5,581 Fully active user
    awesome triple post

    Hi [email protected], NSF protip: Discussing server drama is frowned upon, and used to be deleted instantly

    now that NS1 is sunsetting it's not so rigorously enforced
  • waflzwaflz Join Date: 2012-09-07 Member: 158459Members Posts: 114 Advanced user
    We were able to hook up with another HL1 server and fix some issues, we think the problems are non existent now :D, well hope.
  • GiGaBiTeGiGaBiTe Join Date: 2003-10-07 Member: 21489Members Posts: 1,115 Advanced user
    awesome triple post

    Hi [email protected], NSF protip: Discussing server drama is frowned upon, and used to be deleted instantly

    now that NS1 is sunsetting it's not so rigorously enforced

    The cause of the crashings was because someone in EvolvNS was sending maliciously crafted malformed packets to servers they didn't like (DaGs server mostly) to either make them crash or to kick all players with garbage errors. I figured it out when I took my server install that had been proven to be stable and coordinated with DaG to smurf as his server, and put up a second server. They immediately started getting EvolvNS members on (which were banned after they started trolling), after which the mysterious crashings and disconnects happened.

    I had Wireshark set to log packets going to and from the server, which I later sifted through and found peculiar packets from a known EvolvNS player that was sending corrupted packet frames and other bouillabaisse.

    tl;dr, there was never any stability problems, it was just trolling and sabotage.
    QUOTE (unknown)
    Admiral, why dont we just breach the hull after overriding the automatic hatchlocks closing procedure?

    Last time we did this an onos just put its fat **** inside the hole and lerks just farted a new athmosphere.
    It looked so gross that we decided to never ever do this again.


    My Website
    NS Map Archive
Sign In or Register to comment.