Server Hosting Help

Crimedog84Crimedog84 Join Date: 2009-08-14 Member: 68485Members
I had this posted in a different section of the forums, didn't see this area before. I will simply copy and paste.

I have a dedicated server box, and I am trying to get an NS server up and running on it.

The valve files I have should all be up to date, I just purchased this server under a week ago and the files were all put on then. Even so I have tried to run hldsupdatetool to make sure, but for some reason it keeps coming back saying old ticket, or something like that. No matter what I try, I was able to update other files a couple of days ago, I'm not sure what this means to be honest, but it may not be a problem as I said the files should be all up to date. I will go back here in a minute and try it with a verify_all just to try that as well.

Anyways, when I start the server I get a bunch of cvars setting and then it has this error:

steamservice.cpp (275) : Assertion Failed: Failed to start in-process Steam Serv

and then it tries to restart again and I get this:

couldn't exec config.cfg
L 08/14/2009 - 22:55:01: Contacting
Connection to Steam servers successful.
VAC secure mode is activated.

Which it ends up being on the map boot_camp even if I set +map co_pulse in the shortcuts command line. I don't know what, if anything, is supposed to be in config.cfg for the server. But I don't have that file. And when I try to join the server it gives some stupid steam verification error. One I've never seen before. But I can still join other servers so it's not just me.

I saved the whole log file if you need any more of it. Best I can tell is it has something to do with this:

L 08/14/2009 - 22:54:58: Server cvar "sv_region" = "-1"

But server.cfg it's set to 0 are there any other files that affect this?

Also comes back later on as this:
L 08/14/2009 - 22:54:59: Server cvar "sv_region" = "255"

Right after the steamservice error.

And not to add further confusion to this, but I checked through the rest of the log and after that, every time it sets sv_region after that it sets it to 0. And still the problem.

I am going to try some stuff, like I said, to see what I can come up with. But I am quite confused, so if anyone has ideas, PLEASE!!


  • TinCanTinCan Join Date: 2006-12-11 Member: 59010Members
    1. Starting from scratch can you verify all of the ns files are in the right folders.
    - Serverfolder
    ** - valve
    ** - ns
    ** - etc...

    2. Do you have a text file called steam_appid.txt in the server folder with the number 70 in it?

    3. Can you post your command line stuff you start HLDS with?
    It should have stuff like this: +maxplayers 16 -game ns +map co_faceoff +exec banned.cfg +mapchangecfgfile "server.cfg"
  • Crimedog84Crimedog84 Join Date: 2009-08-14 Member: 68485Members
    edited August 2009
    The NS folder needs to go inside the valve folder? I thought the mod had to be in the same folder as the hlds.exe file. Inside the valve folder there is no hlds.exe file. Am I misreading what you're saying? Or have I just put it in the totally wrong spot?


    Command line is this:

    -game ns -console +maxplayers 16 +ip -port 27027 I've tried different ports as well. I did at one point have +map co_pulse but it wouldn't actually load co_pulse, it would try and then eventually default to boot_camp

    I did a hldsupdatetool with -verify_all on the valve files. Said they were all good. I realize now what you meant about the folder thing....I was just confused by how you worded it. I do also have the steam_appid.txt and it does say 70

    You know what...I don't have exec banned or mapchangecfgfile do I have to have those in the command line? Because I saw them in some file somewhere...

    EDIT 2

    I just tried with those 2 things same result. Before when I was connecting it gave a weird error message like I said in original post. I had a friend just try to join and it just wasn't responding. No error messages, just not responding for him. I will try and join it myself before too long. I just have a few things going on at the moment.
  • TinCanTinCan Join Date: 2006-12-11 Member: 59010Members
    It sounds like you have the folders in the right place. My ascii graphic stunk, I wanted to make sure you had the NS folder. You are right it should be in the same folder as HLDS (not in Valve).

    This thread may be related but does not seem to have a solution
    <a href="" target="_blank"></a>
Sign In or Register to comment.