NS 3.2 Dedicated Server <not n00b questions>

FTNPhoenixFTNPhoenix Join Date: 2008-10-31 Member: 65340Members
Hello. My name is [FTN] Phoenix. I'm trying to set up a dedicated server, and I have about pulled all of my hairs out of my head.

Before you say it:

-I have already searched the forums.
-I have already read Vadakill's guide.

SO, here's what's happening:

I download the HLDSUpdateTool. Everything OK. I run it to download a "valve" server [hl1 deathmatch] per Vadakill's guide.

I can run a HL1 deathmatch server fine. I can connect to it, run around, shoot, etc.

I download the NS 3.2 dedicated server files from the links on this site. I can run a Natural Selection server that starts OK.

When I add the IP address of the server to my favorites, the server, with the name I gave it, and the map I chose, shows up. When I try to connect, I get:

|IP address: [Blank box]
|Game: [Blank]
|Map: [Blank]
|Players: [Blank]
|Valve Anti-Cheat: [Blank]
|Latency: [Blank]
|Player Name |Score | Time
|Server is not responding.

Server is not responding. Every single time I try to connect, I get this message. I talked to Rico Suave for a few minutes, he told me to check that sv_lan was set to 0, which it is. He told me to try changing the port the server uses from 27015 to something like 27018 so the server and the client don't use the same port. I did that. He also told me to check the ports I had forwarded. I have the following ports forwarded:

TCP & UDP 1200
TCP & UDP 6003
TCP & UDP 7002
TCP & UDP 27005
TCP & UDP 27010
TCP & UDP 27011
TCP & UDP 27015
TCP & UDP 27040

Also, because Rico told me to use 27018, I opened:
TCP & UDP 27018

Also, I read somewhere else to open [and I did]
TCP & UDP 27020

I have deleted all the server files. Downloaded new HLDSUpdateTool and NS 3.2 dedicated server files from different sites, and still get the same problem. I have tried running the hlds.exe from the command prompt, from the GUI, and from a .bat file (like Vadakill says), and none of them work. I have added "ip externaliphere" to the server.cfg. I have tried "ip xxx.xxx.xxx.xxx" to the server.cfg file.

I have tried everything I can think of, and it just works for HL1 Deathmatch and just does __NOT__ work for NS. I am at a loss. Please help me, but please do _NOT_ send me to:

-Vadakill's guide. It's bookmarked. I've read every page 10 times.

-Search the forums. I've read every post I thought was applicable here and on other forums.

-Google. I've read every page the search results turned up.

-#nsserver on gamesurge.net. The people on that channel are idle, afk, blind, comatose, or otherwise preoccupied/unresponsive. A chat is no help if there is nobody to chat with.

Please help me.


  • FTNPhoenixFTNPhoenix Join Date: 2008-10-31 Member: 65340Members
    *******************PLEASE DO SOMETHING ABOUT THIS ADMINS*******************************

    Okay, so this is an issue that server admins know already. See these links:

    <a href="http://www.natural-selection.org/forums/index.php?showtopic=105003&pid=1691556&st=0&#entry1691556" target="_blank">http://www.natural-selection.org/forums/in...p;#entry1691556</a>
    <a href="http://www.naturalselection.com/forums/index.php?showtopic=104988" target="_blank">http://www.naturalselection.com/forums/ind...howtopic=104988</a>

    The dedicated server links from this website (I tried 5 different mirrors... a LONG TIME downloading) do not contain the file:


    I'm sure nobody cares how I figured it out, but this is the cause of my problems with the server. It is a file that is not mentioned in Vadakill's guide, it is not a file included with the dedicated server files (BTW - What makes the dedicated server files any different than the client files? They all look the same to me...).

    You have to add the steam_appid.txt file to your "NS" directory for your HLDS.exe. Enter the number "70" (no quotes) in the text file, then save it. Ta-Da. The server works.

    Site admins, please revise the dedicated server .zip's to include the steam_appid.txt. IF you can get a server to start AND respond without this file, I would be THRILLED to know how, but I bet you can't. So please spare someone the frustration I've dealt with. I'm going to repost this in the tech support forums too, and I'm going to put in some extra words in this post to help people find it, because I thought I was having an issue with several things before I figured out what it was.

    I searched for:
    Dedicated server not responding
    Port forwarding
    Server crash
    Dedicated server problem

    And read *every* post those turned up before I figured out the problem.

    Again, please, sticky this somewhere or write your own and sticky it or something. And please update those files. I've honestly spent about 20 or 25 hours trying to get this to work. All for one text file with 2 characters in it. Pfft. [angry face]
Sign In or Register to comment.