Dedicated Ns 2.01 Internet/lan

DL_SKINZDL_SKINZ Members Join Date: 2004-01-07 Member: 25150Posts: 5
How to setup a dedicated NS 2.01 Server
Hi There,
I am currently trying to create a dedicated Natural Selection server utilizing STEAM.
I've been through almost all the posts regarding servers at the natural-selection.org forums and the steampowered.com forums, but alas I am still not able to get this working. Any help would be much appreciated.
Below is the scenario:

Problem: Unable to join server once it is running either via LAN, or internet.

Server: Pentium 4 1.8, 512MB DDR, 20GB HDD, Windows XP Pro with all updates and no firewall.

Network: Cable modem with 1.8Mbps down/256Kbps up with a Linksys BEFSR41 router between modem and machines. Port forwarding is on for ports 1200 (heard this was for STEAM) and 27015 (for Half-Life) utilizing both TCP and UDP and to the proper internal IP address.

Software Installed: HLDS v1120 (STEAM) w/updates, NS 2.0 server and NS 2.01 update

Steps taken:

1) Downloaded the hlds_v1120.exe from fileshack.com.
2) Downloaded ns_v2_dedicated_server.zip from fileshack.com
3) Downloaded ns-v201.zip from fileshack.com
4) Installed hlds_v1120.exe and used all defaults (Directory is c:\hlserver)
5) Created STEAM account via hldsupdatetool.exe using (c:\hldsupdatetool.exe -create <email> <password> <question> <answer>) First it updated the update tool to version 4, then I ran the same command again and it said that the account was created successfully.
6) Updated the HLDS software via the hldsupdatetool.exe using (c:\hldsupdatetool.exe -update valve c:\hlserver <email> <password> Y) Worked flawlessly.
7) Continued to update the following games: Cstrike, TFC, DOD. Worked flawlessly.
8) Unzipped ns_v2_dedicated_server.zip and placed resulting "ns" folder under c:\hlserver. File structure now reads c:\hlserver\ns.
9) Unzipped ns-v201.zip and placed resulting files in "dlls" folder under "ns" folder.
10) Created shortcut to HLDS.exe file under c:\hlserver onto desktop. Renamed it to "NS Server" and changed "Target" to read (c:\hlserver\hlds.exe -console -game ns).
11) Created another shortcut for Cstrike and changed "Target" to read (c:\hlserver\hlds.exe -console -game cstrike)
12) Added the following lines to my "server.cfg" file under the "c:\hlserver\ns" using notepad (sv_region 1, ip x.x.x.x (set to external IP), mp_uplink 0, sv_lan 1). I made sure there were no duplicate CVARs loading during startup. I also tried with mp_uplink set to 1 and sv_lan set to 0 to use on Internet, but no luck there either.
13) Double-click shortcut for NS Server on desktop, and a DOS window appears with the word "Console" in the top bar. Below is a readout of what is listed in the Console:

99.8 fps 0/6 on
Console initialized.
Protocol version 47
Exe version 1.1.2.0 (valve)
Exe build: 09:04:04 Nov 25 2003 (2588)
STEAM Auth Server
couldn't exec language.cfg
Server IP address 192.168.1.103:27015
_ (This is blinking cursor)

14) Launch Natural Selection from my Steam Client on separate machine behind same router (which has worked on multiple Internet servers already, so this is fine). But I cannot see my server in server list, and I cannot see it in the LAN list (when using different CVARs for each). I tried to add the IP for the server in my Favorites list, but it did not show up there either.

This is where I am at now. If anybody has had any luck with this at all, please let me know. I did get the server working for Cstrike, but it will only let me join the LAN game. When I added the IP in my favorites and tried to join it, it said something about invalid STEAM tickets or something. So I'm guessing the server works and I was able to see it on the Internet for Cstrike, but just not for Natural Selection. I've seen several posts where people just said to wait for 3.0, but I'm hoping that someone here has it working and could lend a hand.
Thanks in advance for all of your help.

Comments

  • LumpyLumpy Members Join Date: 2003-08-20 Member: 20026Posts: 57
    edited January 2004
    I'm not sure what if any of the following applies to you. I've only included it so as to not need to ask 20 questions to see exactly what you are and are not doing. Keep in mind these instructions work for any server. ie cstrike, dod, ns.

    It sounds like you're not specifying enough arguements to start the server fully.

    You can test this by issuing a status command at the command prompt aka blinking cursor. It most likely will state "Can't "status", not connected."

    To start the server succesfully you need to specify a starting map at the minimum. You normally do this via the command line like so:

    C:\hlserver\hlds.exe -console -game ns +map ns_bast

    You can also specify how many players and the port etc. See example 1.

    Alternatively you can just start the server with c:\hlserver\hlds.exe -console -game ns and put additional arguements in the autoexec.cfg file which you may need to create inside the ns folder. See example 2.

    Example 1: C:\hlserver\hlds.exe -console -game ns +maxplayers 12 +map ns_bast +port 27016 +log on

    Example 2:
    contents of autoexec.cfg
    maxplayers 12
    map ns_bast
    port 27016
    log on
    user posted image
  • DL_SKINZDL_SKINZ Members Join Date: 2004-01-07 Member: 25150Posts: 5
    Hey Lumpy,
    Thanks a lot for your reply, that made a HUGE difference!!! Still a problem though...
    I was able to connect to the server via LAN now, with either the CVARs sv_lan set to 0 or 1, and mp_uplink set to 0 or 1. This I thought odd since the sv_lan set to 0 should not allow LAN connections at all and it did. Either way though, I was still not seeing my server listed in the Internet games, and if I tried to add the server IP (external IP address with correct port, see first post), it did not find it. Any thoughts on the Internet part?

    Thanks in advance for any help.
  • DepotDepot The ModFather Members Join Date: 2002-11-09 Member: 7956Posts: 6,411 Fully active user
    edited January 2004
    QUOTE
    Network: Cable modem with 1.8Mbps down/256Kbps up with a Linksys BEFSR41 router between modem and machines. Port forwarding is on for ports 1200 (heard this was for STEAM) and 27015 (for Half-Life) utilizing both TCP and UDP and to the proper internal IP address.
    You failed to open the proper ports in your router for a Steam server to show up on the list, this is certain. I'll get back to you on this.

    The ports that need to be opened are :
    • UDP 1200
    • UDP 27000 to 27015 inclusive
    • TCP 27030 to 27039 inclusive
    Let us know if this solves your problem.
    image
    modNS Forums - NS1 and NS2: We Wrote The Book On NS Moddingimage
  • LumpyLumpy Members Join Date: 2003-08-20 Member: 20026Posts: 57
    This FAQ from steampowered.com makes it sound like those ports are only needed to log onto steam and to make sure your firewall isn't blocking them for outgoing connections.

    http://steampowered.com/index.php?area=faq...915705,97731900

    The steam linuxreadme.txt also states

    7) I am behind a firewall. What ports need to be opened for hlds?

    Incoming UDP to local destination 27015.
    Outgoing UDP to remote destination 27010, 27012, 27040.
    Outgoing TCP to remote destination 7002.

    I can't imagine the windows readme is that much different. So basically just make sure your router forwards incoming ports to your server, and any firewall you have on the router or the server doesn't block outgoing ports.

    I only forward port 27105 to my steam DoD server and people can connect to it no problem. I also can connect to any other server via my client box without needing to forward ports to it.

    Even though it's setup as an internet server I am able to play on it myself even though I connnect to it via LAN.

    I have my non steam NS 2.01 server running with sv_lan 0 and mp_uplink 1 yet I'm also able to play on it via my LAN connection. Other people are able to connect to it also.

    As for not seeing yourself in the list...it's been so long since I've used a hardware router that I can't remember if this worked for me or not. I'm 70% sure that I could find myself in the list. Or else enter my external IP and my server would show up in the list.
    user posted image
  • DL_SKINZDL_SKINZ Members Join Date: 2004-01-07 Member: 25150Posts: 5
    edited January 2004
    All,
    Upon further investigation, I discovered a few things:

    1) In following Lumpy's example above, I had added the line "port 27016" to my "autoexec.cfg" file. Although I had only opened port 27015 on my router. I feel especially dumb since I am Cisco certified. sad.gif I have thus switched this to read "port 27015" and all is well.

    2) I tried a myriad of different port combinations, but found that the only port I needed to forward was port 27015 which was the port my game server is running on. I am forwarding both TCP and UDP packets.

    My server (Pickle's Palace of Pain) shows up just fine now. I will attempt to now install MetaMod and a variety of plugins such as UnStuck Pro. Thanks for everybody's input/help. It definitely sped the process up!!!

    Cya L8r.
Sign In or Register to comment.