I can no longer make excuses

Rooks_NemesisRooks_Nemesis Ontario Join Date: 2016-06-11 Member: 218388Members
I've been playing Subnautica now since the first week it showed up on my Xbox one through the preview program, and INSTANTLY was hooked. With all the bugs and issues it was VERY new and exciting (even with the lack of Reapers)..

Through all the updates which where far and few between then and now, I held onto the hope and knowladge that when this beautiful game finally went V 1.0 I would finally be able to sit back and enjoy it at its best!. And then it launched...

Seriously? are you joking? this is a joke right? New version SAME issues..

Wrecks missings scannable equipment pieces ALL together lifepod 17 wreck, mountain wreck and island wreck. Spent 2 hours scouring the mountain biome ( enforcement platform ) only to find percisely 2 shalestone chunks. Mind you there was only 4 reginalds the whole time aswell. Dont get me started on sandstone chunks aswell, INTIRE areas completely devoid of flora, fauna or geological outcrops. The deep lava vent that borders the shallows and kelp forest was my go to location early on for silver and gold, after 10 NEW games a combined total of 7 outcrops appeared. Then theres the flippin seamoth debacle, take it out the first time and end up being trapped out of the map because the sea floor didnt load..

I can go on here with other damn near game breaking concerns, but most have allready been reported or talked about in the forms..

Before it is asked of me, Yes I deleted the game %100 from my system and re installed it a couple times now. I have 83 gigs remaining open on my system. I have even installed the game onto my childrens xbox one ( which has NEVER seen the game on it period ) although with slight variations of the issues, the issues still exist. Ive also EASILY spent well over 300 hours in the game, so I can safely and confidently say I know how to find what im looking for in the game.

I can no longer keep telling myself its just a phase in the development , they will get it fixed by launch. I'm actually quite upset after waiting SO many months from the last update to the launch that there could be this many glaring issues..


  • elfcrisiselfcrisis Join Date: 2017-05-13 Member: 230466Members
    Sounds like you're encountering the resource spawning bug. In another thread, Obraxis said that they have a fix for this going through Microsoft certification right now. This can take a few days, up to a week sometimes. I'm not super confident that it'll actually be fixed, but I guess we'll see.
  • RboxRbox Belgium Join Date: 2018-03-17 Member: 239227Members
    We had someone like that at work: she had to revise a document and take out errors. We almost always got it back with new errors. Sacked the -not so good at her job person (cu**)
  • Jman426Jman426 United States Join Date: 2018-12-16 Member: 246039Members
    I've only been playing for about a week and a half. Issues I've run into. Early in the game? Very little other than a lack of resources spawning. I had to search far and wide and I do mean far and wide just to progress. As my game progressed, more issues started showing up. One is that every stalker and gasopod disappeared. I had to find stalker eggs and build the alien containment tank so I could get stalker teeth. I have a Seamoth stuck in a very small tunnel because the ground would not load in. It was just my bad luck that when the ground did load in, I was in that tunnel.I was lucky to be able to get out of the Seamoth and be able to access the upgrades panel on it. Now, onto my base. The moon pool stops working. In other words, you sail your Seamoth up to it and you just bounce off the water. The only fix is to deconstruct the vehicle upgrade station. You can reconstruct it afterwards but it will continue to happen. I had just started to venture into the lost river when the next issue cropped up. I cannot save the game while in my base. I lost several hours game play on 4 different occasions before I randomly tried saving outside my base. It worked, the save completed. So out of curiosity, I went back into my base and tried to save again. The game crashed again.
    I packed up that entire base with the exception of 3 buildings and moved to the Cove tree cavern in the lost river.

    Initially, this seemed to correct all the issues I was having. I saved and let my son log in and play his game on his account. He is also having issues some the same, some different than mine. Anyhow, back to my new base. After my son quit because he'd lost over 2 hours of game play to a crash while saving. I reloaded my game and noticed that the issues had started again. You'll know your base is glitches when the animation for climbing out of the water in your moon pool doesn't play. You get flung out of the water like you jumped. You'll start noticing the legs on your base and moon pool won't load at all, or they'll only be half as long as they need to be. The bouncing off the water when you try and dock with it is close behind. Followed by not being able to save while inside your base.
    I needed diamonds, so I set off to the Sea Treaders path in my Seamoth. I was on the surface sailing towards what was left of my surface base when the game AGAIN crashed unexpectedly. It seems like the further i not the game you get, the more unstable it becomes until it is near unplayable. I have to take a longer way out of the lost river when I use my Seamoth because the caverns around the disease research base won't load and there's a warped there who has repeatedly teleported me out of my Seamoth while I sit and wait for the land to load. I nearly died to a Reaper while waiting near the entrance to the lost river for the hole in the Sea floor to load. It never did and I was jumped from behind by the Reaper. I was able escape the Reaper and repair my Seamoth I went back and the ground still had not loaded. I sailed my Seamoth over the top of a small ridge and turned back to see if the ground had loaded and there it was. So I sailed back to my original spot and guess what, no ground. So I sailed back over the ridge and voila the ground was there. I use that entrance to the Lost River because it's a straight shot to the Cove Tree cavern where my base is. I have to make sure I approach the entrance from the left if your sailing away from the life pod. If I approach from the right, the ground never loads.

    Certain areas have a crap ton of lag. The cavern with the gargantuan skull and precursor cache is one such area. Another is the disease research base area, as I mentioned before.

    I realize that the game is still being worked on but come on. We save so we don't lose progress. For the game to crash while saving is BS. I'm so frustrated I may not ever play the game again. Update 84 was supposed to fix a lot of bugs. I'm glad I wasn't playing before update 84 because if they fixed a lot of bugs with that update, the game had to be completely unplayable prior to it. Saving is a basic part of nearly all games for crying out loud! Crashing during game play is to be expected every now an then but not during saving.
Sign In or Register to comment.