[Exp. build 16753] Air floating bug

RatskroneRatskrone DE Join Date: 2015-04-05 Member: 203005Members Posts: 17 Fully active user
Hi,

dunno if this ever been reported before. Just experienced it for the first time...

- Started a new game on newest build (16753)
- Played for a while (no savegame loaded)
- While diving, the character suddenly did not seem to need oxygen anymore, O² indicator remained at 100%.
- Upmerged. After reaching the surface, i was able to float through the air like in the water...character animations remained.

I stopped flying around to make a screenshot looking at my base+pod from above:

8iyHuJC.jpg

No idea if this is reproducible, didn't hit F3 and entered any command either.
output_log (8 MB) was too huge to let me upload it on pastebin -.-

Comments

  • RatskroneRatskrone DE Join Date: 2015-04-05 Member: 203005Members Posts: 17 Fully active user
    Update: Just recieved the update (16814). Deleted the old savegame and started a new one.

    Happened again, after a while i was able to float up in the air as high as i wanted to (using SPACE).
    Saved the game and restarted it, hoping it would settle the issue. Now it was the other way around...the character sunk to the ocean floor...no swimming possible. Experienced the same thing i read here:

    http://forums.unknownworlds.com/discussion/137350/fell-through-the-world#latest

    No Oxygen loss, character was walking instead of swimming, using SPACE made him jump only.
  • RatskroneRatskrone DE Join Date: 2015-04-05 Member: 203005Members Posts: 17 Fully active user
    Sorry for multiple posting, but after recieving no feedback here it appears that this "flying bug" i described does not concern many others? I haven't found a similar thread either (also searched the Steam forums).

    As this bug hits me in every single game i start, experimental build is unplayable for me for a week now.
    Already reinstalled the game completely a couple of times, what else can i try?
    As - like mentioned - the output_log file is much too big to upload it on any open platform, maybe i could send it to a helpful dev that has too much spare time (*grin*) per mail?

    Once again in short, this is what happens to me every time i start a game (randomly after 30-60 min.):

    - Exiting seabase, character swims and interacts normally but suddenly doesn't use oxygen anymore...i could dive forever.
    - When upmerging to the surface, i can fly using WASD or SPACE...like being underwater.
    - Saving and reloading the game causes the character to act underwater like he was in a seabase/aurora. Sinks to the ocean bottom like a stone where he can only walk and jump instead of diving.

    I'm playing build 17272 now, bug first surged on build 16753 - but never before.

    Greets,
    Rats



    Zergonuz
  • ZergonuzZergonuz USA Join Date: 2015-04-08 Member: 203114Members Posts: 78 Advanced user
    Hey, I have noticed it is a bug with getting in/out of seabase as you correctly noted.

    If you save while inside seabase, and then exit, you will notice that when you go to re-enter seabase you cannot and that your oxygen won't go down. This automatically is a tip-off that the game has glitched and you will have to reload. It happens no matter if you start a new game or not, or whether you have been playing for 5+ hours on a single save like I have. I NEVER save inside base anymore as since this glitch started I haven't had a single time where it didn't corrupt the game file.

    They need to fix this seabase save glitch where the game thinks you are still inside seabase when you exit it after saving. For now, just do the work-around and never save inside any vessel or base and you will notice those glitches don't happen hardly ever.
    Ratskroneleopardsp0ts
  • leopardsp0tsleopardsp0ts Canada Join Date: 2015-04-27 Member: 203887Members Posts: 6 Fully active user
    This keeps happening to me and I wasn't sure if it was saving in my seabase or fabricating and then exiting, thanks for clearing that up. I'll stop saving in base.
  • RatskroneRatskrone DE Join Date: 2015-04-05 Member: 203005Members Posts: 17 Fully active user
    Zergonuz wrote: »
    If you save while inside seabase...

    Makes sense now. Actually i always saved games inside a seabase/cyclops and never outside, so this must be the reason this bug hit me every time.

    Thanks for the advice, i'll stick to it and see what happens :)

  • VandragoraxVandragorax United Kingdom Join Date: 2015-02-24 Member: 201533Members, Subnautica Playtester Posts: 141 Fully active user
    Hey guys, this issue should be fixed in experimental build and just needs re-checking for confirmation of the fix. If any of you are running experimental please feel free to report back :)

    https://trello.com/c/7bVsQUau/460-player-unable-to-exit-seabase-cyclops-state-flying-with-swim-animation
    7espyBC.png
  • ZergonuzZergonuz USA Join Date: 2015-04-08 Member: 203114Members Posts: 78 Advanced user
    Just tested on my save files and a few new games; all worked fine saving inside seabase and Cyclops. Seamoth didn't teleport like it usually does either; woot!
    Vandragorax
Sign In or Register to comment.