GLSL Compiler

AsfridurAsfridur Join Date: 2013-08-31 Member: 187480Members
I set my game's options to OpenGL recently and since the restart, I haven't been able to open the game due to GLSL Compiler crashing constantly. I've tried putting in specific start-up commands, I've deleted, restored and tried adding some extra files but nothing seems to work out, the OpenGL settings have been saved to the Steam Cloud. Following the Compiler's crash, NS2.exe follows with it.


  • AsfridurAsfridur Join Date: 2013-08-31 Member: 187480Members
    Nobody knows what's wrong..?
  • dignomedignome Join Date: 2003-08-04 Member: 18853Members, Constellation, Reinforced - Shadow
    Perhaps try wiping out the '%APPDATA%/Natural Selection 2' folder which contains the configuration file. When you start NS2 again it will re-create the contents of this folder.
  • AsfridurAsfridur Join Date: 2013-08-31 Member: 187480Members
    I've already tried this before, nothing seemed to really happen. The settings are saved to the Steam Cloud, I believe, and are set to automatically reapply on start of the game, disconnecting it from the Cloud didn't seem to work either so I may be wrong.
  • MilaniumMilanium Join Date: 2012-12-27 Member: 176388Members
    edited September 2013
    Don't just wipe out the whole configuration file. Go to %APPDATA%/Natural Selection 2 and search for that XML and delete the line that says

    it will then default to the DirectX renderer and did not grab something from the Steam cloud when I tried it.

    By the way: that setting is confusingly labeled: device is like a hardware graphics card for me, not a renderer.
Sign In or Register to comment.