Cannot use apostrophe ' as a keybind

CerziCerzi Join Date: 2012-02-07 Member: 144119Members
I know, an odd one to report, but as I use the Dvorak keyboard layout, the apostrophe key is actually where the Q key is on a regular keyboard, making it a rather useful key to bind. Comma and period bind perfectly fine (W and E on qwerty), but not apostrophe.

If this is something that could be fixed easily then me and the 1 other person who uses Dvorak would really appreciate it!


  • WhosatWhosat Singapore Join Date: 2006-11-03 Member: 58301Members, Reinforced - Shadow
    You could try editing the options key binding file directly, not sure if that will work.

    Its located in \Steam\userdata\<userid>\4920\remote\options.xml
  • __Viking__Viking Join Date: 2012-11-06 Member: 167837Members
    Cerzi, I just registered here for you man.

    I am experiencing the same issue.

    We need more love for Dvorak!

    Also I have attempted to manually set <Q>Apostrophe</Q> in options.xml, but this does not work.

    I've been trying to rebind the keys for commander mode, here's what I can tell you so far:
    There seems to be a problem with the Q key itself and how NS handles this input.
    Leaving <Q>Q</Q> and having <X>Q</X> will make Apostrophe behave as Q and X behave as Apostrophe, both activating Tab1 in commander.
    Changing <Q>Apostrophe</Q> and <X>Q</X> will make BOTH behave as X activating the second slot in row two as commander.

    At this time I am completely baffled and cannot make all of the commander keys work properly in Dvorak. Perhaps the most puzzling of all is that this issue is the same for both the D and E keys. However I have had no problems rebinding <D>E</D> and <E>Period</E>
  • hapveghapveg Join Date: 2012-11-05 Member: 167254Members
    Much love for Dvorak :)

    Same problem with the L key, cannot be rebound at all (shows blank on the rebinding screen, reverts to default when the screen is closed).

    L is used in the left handed version of WSAD (in both QWERTY and Dvorak). Every other key around it can be rebound sucessfully, it seems really strange that rebinding is broken only for certain keys.
  • IronHorseIronHorse Developer, QA Manager, Technical Support & contributor Join Date: 2010-05-08 Member: 71669Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Subnautica Playtester, Subnautica PT Lead, Pistachionauts
    The Q key issue should be sorted for 229
    Commander Keys are hardcoded for the time being, but i expect this will change eventually, as its just a current limitation and an issue that has been discussed many times.
  • TomD22TomD22 Join Date: 2010-12-28 Member: 75995Members
    edited November 2012
    Also cannot bind capslock to push-to-talk (which is driving me crazy 'cos after five years or so using that key for that bind in games, it's impossible to unlearn it!)

    edit: hmm sorry looks like I would have been better bumping <a href="" target="_blank"></a> instead

    edit2: really enjoying the match that's being broadcast on esltv today btw - very much need a spectate option though (as with sourceTV relays in CSS/TF2 for instance) so one can watch games directly
  • TwinTwin Join Date: 2012-11-09 Member: 168597Members
    <!--quoteo(post=2017900:date=Nov 10 2012, 03:48 AM:name=ironhorse)--><div class='quotetop'>QUOTE (ironhorse @ Nov 10 2012, 03:48 AM) <a href="index.php?act=findpost&pid=2017900"><{POST_SNAPBACK}></a></div><div class='quotemain'><!--quotec-->The Q key issue should be sorted for 229<!--QuoteEnd--></div><!--QuoteEEnd-->
    I'm having an issue with the Q key too, I can't take it off Taunt for some reason.
    Also, I can't seem to bind the number keys 1-9. (I'm using a UK layout if that makes a difference)
    NS2 lists them ingame as "1", but this doesn't work (the console tells me key not found).
    I have to edit options.xml and instead of "1" I need to use "Num1" and that works. However "Num2" cannot be bound to Taunt...

    I made a thread about it <a href="" target="_blank">here</a> but I think I posted it in the wrong section!
  • airtekhairtekh Join Date: 2012-11-10 Member: 169003Members, Reinforced - Shadow
    Friendly bump, seeing as this issue is still affecting me as well.

    I cannot bind apostrophe (') and semicolon (;) to anything at all, and seeing as they map to 'Q' and 'Z' on a QWERTY layout, that's two useful keys that I cannot utilise!

    Also, the commander key layout is totally screwed for anyone who doesn't use QWERTY. At the very least it should be rebindable, but again it would be a problem for Dvorak users like myself due to the aforementioned unbindable keys.
  • __Viking__Viking Join Date: 2012-11-06 Member: 167837Members
    edited November 2012
    To get around this issue in 228 I shifted all of the keys for commander over one to the right, so ',.P->,.PY AOEU->OEUI ;QJK->QJKX. This avoids both the ' and the ; keys. It took some getting used to, but since I've acclimated I haven't tried to rebind them to normal in 229.

    <!--c1--><div class='codetop'>CODE</div><div class='codemain'><!--ec1-->        <A>O</A>

    I used H here as a null key that isn't used in the interface to ensure that there were no key collisions.
  • deadliftdeadlift Join Date: 2013-01-07 Member: 177994Members
    edited January 2013
    I'm sad to see that the DVORAK issue hasn't been resolved. I really like this game, <b>the issue can be very easily reproduced by installing the "United States (Dvorak)" layout and setting it as the default.</b>

    Inside the game, you'll realize that it's not possible to bind the Q key correctly, and even changing the bindings in options.xml is not solving issues with the commander bindings.

    It's not only the Q key that has a problem, when rebinding the commander keys, pressing D (which is the equivalent of E in Dvorak) is incorrectly activating the E key, despite the "<D>E</D>" binding I have in options.xml.

    Please look into this you guys, I don't have this problem with other games, like Crysis (CryTek being a foreign developer, they must be used to dealing with non-standard keyboard layouts).

    So this problem can be solved, it's easily reproducible, and I believe it has something to do with how NS2 is reading the keys.
  • AgielAgiel Join Date: 2006-11-14 Member: 58605Members, Constellation, NS2 Playtester, Subnautica Playtester
    As a former Dvorak user who switched to Colemak about 5 years ago, I can say I have multiple reasons for not regretting the switch. I very much sympathise with you guys though ;)

    I don't see much happening in this area until the new key binding system is implemented. Hopefully it'll be done soon.
  • fivesevenfiveseven Join Date: 2012-11-26 Member: 173272Members
    AFAIK UWE are working on a proper key binding system for their upcoming big release. Until then is it really a big deal to just switch back to qwerty? Its all of a mouse click in your system tray, or even a global hotkey.
  • deadliftdeadlift Join Date: 2013-01-07 Member: 177994Members
    <!--quoteo(post=2057539:date=Jan 7 2013, 02:00 PM:name=fiveseven)--><div class='quotetop'>QUOTE (fiveseven @ Jan 7 2013, 02:00 PM) <a href="index.php?act=findpost&pid=2057539"><{POST_SNAPBACK}></a></div><div class='quotemain'><!--quotec-->Until then is it really a big deal to just switch back to qwerty? Its all of a mouse click in your system tray, or even a global hotkey.<!--QuoteEnd--></div><!--QuoteEEnd-->
    That's great news, I didn't know they were redoing the key binding system. :D

    I'm aware of the "switch layout to QWERTY" workaround, but you have to understand that I wouldn't be able to type in chat, team chat, or use the console because the keys on my keyboard are actually switched to Dvorak. I'm sure ppl can touch type in QWERTY, but it's not as easy when you memorize another layout for touch typing, like I did with Dvorak, and even less so by looking at the keyboard because there wouldn't be a QWERTY layout to look at! :)

    I hope you can understand how this is a major annoyance for me. :( I can hardly wait for them to fix this, because I really like this game.

    Also, for some odd reason the global hotkeys are not working for me on Windows 7, they reset as soon as I set them. I was planning on using them if I got into the comm chair or something. I'll look into that some more.
  • deadliftdeadlift Join Date: 2013-01-07 Member: 177994Members
    It's March, and the problem with commander key bindings persists in the latest build. It seems to have improved, but I can't use the top row (Q, W, E, and R), which severely hampers my ability to comm effectively. Is UWE really working on a better key binding system, or is it out already?

    I'd appreciate any update on this.
  • deadliftdeadlift Join Date: 2013-01-07 Member: 177994Members
    Are they done working on this new key binding system?
Sign In or Register to comment.