Getting This Error When Trying To Start Ns Server

mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
OK I get the following when I try to start the NS server. I have included the command that I using to do this. Now I can start a valve server with out and probelms. I have tryed every fix that I can find so far here in the forums and still can not get this to start up. Any help would be great. This is on a Linux box.


CODE

./hlds_run -debug -game ns +maxplayers 10 +map ns_hera
Auto detecting CPU
Using default binary.
Enabling debug mode
Auto-restarting the server on crash

Console initialized.
scandir failed:/home/hlds/hlds_1/./platform/SAVE
Protocol version 47
Exe version 1.1.2.0/Stdio (valve)
Exe build: 02:38:15 Jul  7 2004 (2738)
STEAM Auth Server
Server IP address 66.221.231.33:27015

  Metamod version 1.17.2  Copyright (c) 2001-2004 Will Day <[email protected]>
  Metamod comes with ABSOLUTELY NO WARRANTY; for details type `meta gpl'.
  This is free software, and you are welcome to redistribute it
  under certain conditions; type `meta gpl' for details.

scandir failed:/home/hlds/hlds_1/./platform/SAVE

Executing Admin Mod config file
Executing Admin Mod config file
./hlds_run: line 57: 30108 Segmentation fault      (core dumped) $HL_CMD

warning: Unable to set global thread event mask: generic error
Error while reading shared library symbols:
Cannot enable thread event reporting for Thread 1024 (LWP 30108): generic error
Error accessing memory address 0xbffff660: No such process.
339     vfscanf.c: No such file or directory.
Error accessing memory address 0xbffff660: No such process.
debug.cmds:1: Error in sourced command file:
Error accessing memory address 0xbffff658: No such process.
email debug.log to [email protected]
Mon Apr 25 11:59:35 CDT 2005: Server restart in 10 seconds
Mon Apr 25 11:59:40 CDT 2005: Server Quit

Comments

  • BorisBoris Join Date: 2002-12-30 Member: 11636Members Posts: 215
    is the -debug necessary? and have you tried a STOCK NS server? Take away MM and AM and try that first.

    Next, why would you run AM, it basically has lost all support for NS, AMXX is the only thing really to use now, and update your MM as well...
    Mr|Server(FF)
    ns.mrcommunity.ca:27015
    Mr|Community
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    If I run the command with out debug all that is out puted from the server is the following.

    Server crashed run with -debug to find the problems and fix it.

    And this is happening with a stock NS server as well.

    So with this new info what could becuaseing this becuase I sure can not find the problem.


  • BorisBoris Join Date: 2002-12-30 Member: 11636Members Posts: 215
    edited April 2005
    I haven't worked much with linux steam servers since they now SUCK for linux, but I suggest you start searching for some posts about some error msgs (on the www). Start with maybe this one:
    QUOTE
    ./hlds_run: line 57: 30108 Segmentation fault

    Google might come up with something. If not, wait patiently, and hopefully someone has had this problem before and know's how to correct it. In the mean time, why don't you post some details about your linux setup including kernel versions and distribution. Any info might point to a problem. Good luck!
    Mr|Server(FF)
    ns.mrcommunity.ca:27015
    Mr|Community
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    If a generic valve DM server works, NS should work as well. Re-install the NS server from scratch, use my guide (in my sig) if you want to know exactly what you should be doing. When you re-install run the server vanilla *first* before you install *any* mods just to prove it works. After that you can work on modding it.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    Even with a vanilla NS install I'm getting the same errror. I have tryed about every thing I can to get this to work but it is not working out.
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    I think I mgiht have found the problem. I will post if I fixed or not.
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    I did not get it fixed. Here is what I get after a clen install.

    bash-2.05$ ./hlds_run -game ns +exec server.cfg +maxplayers 12 +map ns_eclipse
    Auto detecting CPU
    Using default binary.
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/hlds/hlds_1/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 02:38:15 Jul 7 2004 (2738)
    STEAM Auth Server
    couldn't exec language.cfg
    Server IP address 66.221.231.33:27015
    scandir failed:/home/hlds/hlds_1/./platform/SAVE

    ./hlds_run: line 57: 7072 Segmentation fault $HL_CMD
    Add "-debug" to the ./hlds_run command line to generate a debug.log to help with
    solving this problem
    Wed Apr 27 03:05:55 CDT 2005: Server restart in 10 seconds

    Console initialized.
    scandir failed:/home/hlds/hlds_1/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 02:38:15 Jul 7 2004 (2738)
    STEAM Auth Server
    couldn't exec language.cfg
    Server IP address 66.221.231.33:27015
    scandir failed:/home/hlds/hlds_1/./platform/SAVE


  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    I forgot to patch the NS server and still after patching I get the following.
    bash-2.05$ ./hlds_run -game ns +exec server.cfg +maxplayers 12 +map ns_eclipse
    Auto detecting CPU
    Using default binary.
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/hlds/hlds_1/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 02:38:15 Jul 7 2004 (2738)
    STEAM Auth Server
    Server IP address 66.221.231.33:27015
    scandir failed:/home/hlds/hlds_1/./platform/SAVE

    ./hlds_run: line 57: 7224 Segmentation fault $HL_CMD
    Add "-debug" to the ./hlds_run command line to generate a debug.log to help with
    solving this problem
    Wed Apr 27 03:12:27 CDT 2005: Server restart in 10 seconds
    Wed Apr 27 03:12:32 CDT 2005: Server Quit
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    OK here is the Hafl Life server running.


    bash-2.05$ ./hlds_run -game valve +exec server.cfg +maxplayers 12 +map crossfir
    e
    Auto detecting CPU
    Using default binary.
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/hlds/hlds_1/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 02:38:15 Jul 7 2004 (2738)
    STEAM Auth Server
    Server IP address 66.221.231.33:27015
    scandir failed:/home/hlds/hlds_1/./platform/SAVE

    No auth servers parsed
    Disabling Valve Authentication.
    Adding master server 207.173.177.11:27010
    Adding master server 69.28.151.178:27010
    stat
    hostname: Day Web Hosting
    version : 47/1.1.2.0/Stdio 2738 insecure
    tcp/ip : 66.221.231.33:27015
    map : crossfire at: 0 x, 0 y, 0 z
    players : 0 active (12 max)

    # name userid uniqueid frag time
    ping loss adr
    0 users


    ALso How the heck do I set the rcon_password?
  • BorisBoris Join Date: 2002-12-30 Member: 11636Members Posts: 215
    how did you get it to work?

    and to answer your question, you actually typed the right thing already:
    rcon_password "password"
    that's set in the server.cfg

    in your client you set similar things, if you type rcon into the console you'll see the few options you can set. If you are connected to the server you just need to enter the password. If you want to rcon without connecting to the server (play game), then you must enter the rcon_address and rcon_port. As well, to enter rcon commands you type: "rcon <command>" - you need that rcon infront of everything to tell it to send over rcon.
    Mr|Server(FF)
    ns.mrcommunity.ca:27015
    Mr|Community
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    What distro of Linux are you using?
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    Red Hat Linux release 7.2 (Enigma)
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    edited April 2005
    I think I found why I'm getting that error.
    It is becuase I'm using bash to run it from.
    But when I logged in as root and run the command here is what I get from it.

    [[email protected] hlds_1]# ./hlds_run -game ns +exec server.cfg +maxplayers 12 +map ns_eclips
    e
    Auto detecting CPU
    Using Pentium II Optimised binary.
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/hlds/hlds_1/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 02:38:31 Jul 7 2004 (2738)
    STEAM Auth Server
    Server IP address 66.221.231.33:27015
    scandir failed:/home/hlds/hlds_1/./platform/SAVE

    No auth servers parsed
    Disabling Valve Authentication.
    Adding master server 207.173.177.11:27010
    Adding master server 69.28.151.178:27010


    BUt when I go back and run the server the other way I get the error again.

    My question is how do I get the promte like the root one for the user one?
  • VadakillVadakill The Almighty BSO Join Date: 2002-04-02 Member: 373Members, NS1 Playtester Posts: 874
    edited April 2005
    Well, I know for a fact that Redhat 7.3 runs NS, I still use that; I don't know if 7.2 will work. It's possible that the C libraries on 7.2 aren't new enough, I'm not certain of that though.
    [NAPT]Vadakill

    NS Win32/Linux Server setup guides:
    http://www.vadakill.com/nsguides
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    OK here is the thing. I can get the NS server to run as root.
    I can not get it to run under any other user name.
    There is something that is not beening access as any other user then root. Here is what I get from a no root user.
    ./hlds_run -game ns +exec server.cfg +maxplayers 12 +map
    ns_eclipse
    Auto detecting CPU
    Using default binary.
    Auto-restarting the server on crash

    Console initialized.
    scandir failed:/home/mbday1/hlds/hlds_1/./platform/SAVE
    Protocol version 47
    Exe version 1.1.2.0/Stdio (valve)
    Exe build: 02:38:15 Jul 7 2004 (2738)
    STEAM Auth Server
    Server IP address 66.221.231.33:27015
    scandir failed:/home/mbday1/hlds/hlds_1/./platform/SAVE

    ./hlds_run: line 57: 27356 Segmentation fault $HL_CMD
    Add "-debug" to the ./hlds_run command line to generate a debug.log to help with
    solving this problem
    Sun May 1 17:51:48 CDT 2005: Server restart in 10 seconds



    If server is started as root then it running fine. SO what is it that I'm missing?
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    OK any ideas why the NS server will only run as root but will not run as a user?
    The Half_life server will run as a user but not NS.
  • BorisBoris Join Date: 2002-12-30 Member: 11636Members Posts: 215
    not to ask stupid questions...but is the directory structure for half-life and ns setup with permissions for non-root users?
    Mr|Server(FF)
    ns.mrcommunity.ca:27015
    Mr|Community
  • mbdaymbday Join Date: 2005-04-22 Member: 49157Members Posts: 12
    Yes they are set up that way.
Sign In or Register to comment.