Nvidia Optimus

LackOfSkillLackOfSkill Join Date: 2012-04-19 Member: 150737Posts: 2Members
Hi there,
I have Win7x64 with all the latest updates to the system and drivers (graphic (both), chipset, sound).
The problem is that in Counter-Strike my dedicated gt540m graphic card is used, but in Natural Selection it is not. I've search through google for my problem, but no it seems that no one has it before. In Nvidia Panel i have CounterStrike(hl.exe) and there i can change graphic card (i've tried to turn it off and i got fps down which means integrated graphic card was on), but i can't change it on HalfLife/hl.exe, the box is grey and only Integrated Graphic Card is shown, even if i tried in Global choosing only High Performance Graphic Card it does not work... And i had to add halflife/hl.exe to the list manually, it does not find it by itself. I tried even runnig HL.EXE, from where NS is installed, by right-clicking and choosin Nvidia card, but the indicator of nvidia optimus does not shown any program that is in use of this technology... Please help me...

Comments

  • DoY_DeAdMeAtDoY_DeAdMeAt Join Date: 2007-03-24 Member: 60469Posts: 12Members
    I have the same problem
    help would be great
  • Kouji_SanKouji_San Sr. Hινε Uρкεερεг - EUPT Deputy The Netherlands, Hoogezand Join Date: 2003-05-13 Member: 16271Posts: 11,379Forum Admins, Playtest Lead, Forum Moderators, NS2 Playtester, Squad Five Blue mod
    edited April 2012
    Hmm, there's a way to disabling the integrated video card in the Bios. Should be easy enough to do actually, you simply disable the integrated video card in the devices section somewhere and save/restart. Your motherboard manual should give you info on how to do this, you can always download a manual from the motherboard brand website as well :)


    Just make sure you stay away from memory timings, CPU/FSB frequencies or voltages and such, if you've never seen/messed around in the Bios settings! If you don't know what it is, do not change the settings. Just posting this warning as I do no know if you guys know about this stuff and what it can do (make it look like your PC is broken, while you can simply reset it back to default)

    However something as simple as disabling the integrated video card is completely risk free and would solve your issue :)
    Post edited by Unknown User on

    Forum Admin "to protect and serve" Admin/Moderator I mostly use a flamethrower tank for disputes... Mostly

    Existence Unknown
    NS2-720p Playlist or on the UWE Forums, last update 11-aug-2012
    NS2: 95x1HP Skulk escapes, latest NS2 Comic #49 GAS: Newton's third law was wrong?

  • LackOfSkillLackOfSkill Join Date: 2012-04-19 Member: 150737Posts: 2Members
    edited April 2012
    Man, you are completely not reading what is it going about, for first: this is a laptop (look at dedicated graphic card, GT540M (M-Mobile)) not a PC and second: in a laptop you cannot change FSB and so on in BIOS :)
    So the issue is still unsolved and i do not see if it is going to be...
    Post edited by Unknown User on
  • ObraxisObraxis Subnautica Animator, Co-Lead NS2 CDT Join Date: 2004-07-24 Member: 30071Posts: 1,749Super Administrators, Forum Admins, NS1 Playtester, Forum Moderators, NS2 Developer, Constellation, NS2 Playtester, Squad Five Silver, WC 2013 - Supporter, Subnautica Developer admin
    Please contact Max, he may be able to help you: max@unknownworlds.com

    Thanks

    If NS2 fails, follow my Nuke From Orbit Guide.

  • DoY_DeAdMeAtDoY_DeAdMeAt Join Date: 2007-03-24 Member: 60469Posts: 12Members
    i have a geforce gt 540m mobile with optimus battery 296.10 nvidia driver
    my laptop is acer aspire 5750g-6496
    i cant seem to force ns to use my graphics card
  • DoY_DeAdMeAtDoY_DeAdMeAt Join Date: 2007-03-24 Member: 60469Posts: 12Members
    edited February 2013
    Ok i found a Fix Download Nvidia Inspector http://www.guru3d.com/files_details/nvidia_inspector_download.html
    install it whereever you please
    open and click the tool icon to the right of Driver Version
    at the top left is profiles.. find your game your looking for and click it
    Now go down to other look for
    Enable application for optimus
    change it to Shim_Rendering_mode_enable
    now you can use your video card on games that otherwise didn't allow it
    Post edited by DoY_DeAdMeAt on
Sign In or Register to comment.