Server Performance is terrible again

Omega_K2Omega_K2 Join Date: 2011-12-25 Member: 139013Members, Reinforced - Shadow Posts: 558
edited February 2014 in Server Discussion
Seeing out maxed CPU with as little as 18 players and a tickrate of 15.

Issue seems be become worse as round progresses, i.e. long games suffer esp. Better after round reset.

http://omegak2.net/ns2/server-0215-225027.plog.bz2

Edit:

This issue seems to appear mainly on long rounds, 40-50+ minutes, regardless of amount of buildings present.
Post edited by Omega_K2 on
German Slaughterhouse | GS Servers | Server Hardware
IGN: [#OMEGA] - K2 (Hive)

NS2 long standing issues (Fix ETA: Never):
Bad Netcode (no adjustable tickrate, extremly delayed hit feedback, bad hitreg),
Bad Performance (Poor Multi-threading, Mouse Lag, bad server performance, almost no multi-threading in server application)
Bad Balance (GL Spam, semi-useless exos, poor chance of comebacks, no upkeep/or RT dimishing returns...)
Technical Issues (Mouse Lag, Memory Leaks, Memory Corruption (and memory corruption server crashes))
Bad Workshop implementation (down = kicks people/connection prboelms, out of date = nobody can join server),

Comments

  • bdbkushbdbkush .ca Join Date: 2014-02-13 Member: 193974Members, Reinforced - Supporter Posts: 20
    Not noticing any decline in server performance here, 18 slot - solid 30 tic with max pop.
    Owner/Operator @ Black Mesa Research Facility

    b_560_95_1.png
  • GhoulofGSG9GhoulofGSG9 Join Date: 2013-03-31 Member: 184566Members, Super Administrators, Forum Admins, Forum Moderators, NS2 Developer, NS2 Playtester, Squad Five Blue, Squad Five Silver, Reinforced - Supporter, WC 2013 - Supporter, Pistachionauts Posts: 2,831 admin
    bdbkush wrote: »
    Not noticing any decline in server performance here, 18 slot - solid 30 tic with max pop.

    You'll notice it as soon as you play a round which is longer than ~60-80 min
    Developer, Modder and Server Admin of Survival of the Fattest - Ingame Nick: Ghoul
    Omega_K2
  • SmashITSmashIT Join Date: 2013-06-07 Member: 185504Members Posts: 11
    You'll notice it as soon as you play a round which is longer than ~60-80 min

    Obviously this isn't a bug then it's a feature to discourage turtles.
  • the_tickthe_tick Netherlands Join Date: 2014-01-20 Member: 193352Members Posts: 97
    when 263 came out I overclocked my server from 4.5 to 4.6 ghz, now I run 2x 28 instead of 26, no performance issues so far
    Owner of the tick's battleground servers
  • ObraxisObraxis Subnautica Animator & QA Lead, NS2 Person Join Date: 2004-07-24 Member: 30071Super Administrators, Forum Admins, NS1 Playtester, Forum Moderators, NS2 Developer, Constellation, NS2 Playtester, Squad Five Silver, WC 2013 - Supporter, Subnautica Developer, Pistachionauts Posts: 3,002 admin
    No performance issues on YO either.

    If NS2 fails, follow my Nuke From Orbit Guide.

    NS2 Discord: https://discord.gg/0TKQwZWu7JEPeAgW

    Subnautica Discord: https://discord.gg/subnautica

    MuckyMcFly
  • ZEROibisZEROibis Join Date: 2009-10-30 Member: 69176Members, Constellation Posts: 1,017 Advanced user
    No instead the main issue continues to be the workshop going down and then you can not play modded servers at all. At least in the case of lag you can still play the game.
    image
    Server IP: NS2.IBISGaming.com
    Server IP: NS2CO.IBISGaming.com
  • ZEROibisZEROibis Join Date: 2009-10-30 Member: 69176Members, Constellation Posts: 1,017 Advanced user
    Has anyone else noticed that performance appears to be even lower in this build. I guess we will know after a few more days for sure but so far it appears tick drops are more common.
    image
    Server IP: NS2.IBISGaming.com
    Server IP: NS2CO.IBISGaming.com
Sign In or Register to comment.