Microstuttering/Input Delay Fixes to try

ObraxisObraxis Subnautica Animator, NS2 Person Join Date: 2004-07-24 Member: 30071Super Administrators, Forum Admins, NS1 Playtester, Forum Moderators, NS2 Developer, Constellation, NS2 Playtester, Squad Five Silver, WC 2013 - Supporter, Subnautica Developer, Pistachionauts Posts: 2,907 admin
edited September 2013 in Technical Support
Hey all - we've been getting reports of Microstuttering and Input delay still - even after some fixes went into 253.

Could you please try the following and report back if these fix your issues, or not:

Open Console

Micro-stuttering Fix


(try switching see which is best)

r_mt true/false or r_mt 1/ 0 (Thanks @Tarrog)

Disable Physx in main menu


Input Delay Fix:



Turn on mouse accel, disable raw input
Then
Turn off mouse accel, turn on raw input

Input delay should be fixed (Thanks mf-)

There is an incompatibility with Mumble/TeamSpeak OVERLAY which can cause framerate drops. Please disable for now.


**UPDATE**

Another thing to try:

Create a new NS2 Shortcut.

Right click on it, hit properties.

Apply the following settings:

noaero.JPG

Run NS2 from this new shortcut. See if your FPS/Input Lag has improved.


Thanks everyone!
Post edited by Obraxis on
Obraxiscurrent1yHyperBowserAconitStardog
«1

Comments

  • elodeaelodea Editlodea Join Date: 2009-06-20 Member: 67877Members, Reinforced - Shadow Posts: 1,786 Fully active user
    r_mt doesn't effect the microstutters for me

    input delay fix works however
    Gorge bilebomb forever.
  • OuchOfDeathOuchOfDeath Join Date: 2013-02-04 Member: 182825Members Posts: 82
    I don't have micro stuttering with DX9, only with DX11 (which I don't use as it's slower) so I'm not gonna comment there.

    The input delay fix doesn't work. It lowers the input lag, but it's still there. Turning raw input on also throws my aim off as I'm used to playing with it off (I use windows' mouse accel), so it's not much of a temporary fix.

  • SebSeb Melbourne, AU Join Date: 2013-04-01 Member: 184576Members, Forum Moderators, NS2 Playtester, Squad Five Blue, Squad Five Silver, WC 2013 - Silver, Community Dev Team Posts: 513 mod
    I don't get stutter with DX11, nor input lag. Is anyone similar to me?

    Specs:
    Gtx680 on 326.41 beta drivers
    i7 3770k
  • HeavenfallHeavenfall Join Date: 2010-08-14 Member: 73620Members Posts: 30
    Obraxis wrote: »
    Hey all - we've been getting reports of Microstuttering and Input delay still - even after some fixes went into 253.

    Could you please try the following and report back if these fix your issues, or not:

    Open Console

    Micro-stuttering Fix


    (try switching see which is best)

    r_mt true/false or r_mt 1/ 0 (Thanks @Tarrog)

    Disable Physx in main menu


    Input Delay Fix:



    Turn on mouse accel, disable raw input
    Then
    Turn off mouse accel, turn on raw input

    Input delay should be fixed (Thanks mf-)

    There is an incompatibility with Mumble/TeamSpeak OVERLAY which can cause framerate drops. Please disable for now.



    Thanks everyone!

    I'm suffering from both Micro-stuttering and Input delay. I tried fixes for both but I see no improvement. In addition, I'm seeing insane FPS drop in combat - often it will go from 50 FPS to 5 FPS or below.
    All to dust
  • Ghosthree3Ghosthree3 Join Date: 2010-02-13 Member: 70557Members, Reinforced - Supporter Posts: 3,416 Fully active user
    Can't seem to fix the stutter, did a quick profile capture and the "RenderThread::WaitForTasks" was spiked really hard during one of the freezes.
    76561197996992409.png
  • TarrogTarrog Join Date: 2013-04-06 Member: 184662Members, Reinforced - Silver, Reinforced - Gold, Reinforced - Shadow Posts: 11
    Just copypasta from reddit.

    FIXED: Stuttering
    CPU: i7 3770k GPU: Gainward GTX 680 Phantom

    My Setup
    • Resolution: 1920x1080
    • VSync: OFF
    • Physx GPU Acceleration: ON
    • Everything maxed out.

    First off all I deactivated multithreading in the console by: r_mt 0 then, activated Physx GPU Acceleration in NS2 in the Options.
    Go to desktop rightklick for Nvidia Settings then ---> SETTINGS and reboot the pc, and try.
    It worked for me. But I'm still sad that it doesn't work smooth like butter but I think UWE is working on better optimization of performance...I hope
  • Dictator93Dictator93 Join Date: 2008-12-21 Member: 65833Members, Reinforced - Shadow Posts: 657 Fully active user
    I would like to point out that the GPU PhysX option in game does not seem to work. If you use the Nvidia Inspector program and turn on the overlay for PhysX it states that the game is not using the GPU for physX... but rather the CPU.

  • NeokenNeoken Bruges, Belgium Join Date: 2004-03-20 Member: 27447Members, NS2 Playtester, Reinforced - Shadow, WC 2013 - Silver, Subnautica Playtester Posts: 1,305 Advanced user
    Enabling Vsync/triple buffering also seems to make the game feel a lot smoother for me, although it doesn't help inputdelay.
    Psychosis - Psi
  • Ghosthree3Ghosthree3 Join Date: 2010-02-13 Member: 70557Members, Reinforced - Supporter Posts: 3,416 Fully active user
    Switching from fullscreen to borderless gave me less hitches, but be careful because alt tabbing in borderless causes a memory leak at the moment which will eventually crash the game. Worth it for smooth gameplay though.
    76561197996992409.png
  • dePARAdePARA Join Date: 2011-04-29 Member: 96321Members, Squad Five Blue Posts: 1,331 Advanced user
    I play around with the different apis (dx9,dx11 and opengl) in combinations with the different modes (windows, fullscreen, fullsceen windows) a bit.

    result:

    DX9 and DX11
    Feels the same on every mode, it seems the game didnt switch beween them. vsync didnt work.

    OPENGL
    VSync is working and it feels smooth with the typical inputdelay.
    Different modes working also.

    Try opengl on windows modes + force vsync via graphics card setup panel:
    No inputlag and smooth @ the cost of one scanline in the top area of the screen. (strange graphic bug)


    image
  • zeepzeep Join Date: 2002-11-01 Member: 3367Members Posts: 281 Fully active user
    Obraxis wrote: »
    Hey all - we've been getting reports of Microstuttering and Input delay still - even after some fixes went into 253.

    Could you please try the following and report back if these fix your issues, or not:

    Open Console

    Micro-stuttering Fix


    (try switching see which is best)

    r_mt true/false or r_mt 1/ 0 (Thanks @Tarrog)

    Disable Physx in main menu


    Input Delay Fix:



    Turn on mouse accel, disable raw input
    Then
    Turn off mouse accel, turn on raw input

    Input delay should be fixed (Thanks mf-)
    Both fixes didn't work. They simply don't give any change. The input delay stays no matter what i try.
    As far as micro stutters go, in-game i can have like 80fps but it feels like 15.

    Maybe this is the problem? He says NS2 is not really running true Fullscreen:
    http://forums.unknownworlds.com/discussion/comment/2144889/#Comment_2144889

    Win7 64, i7 3770k 3.50GHz, gtx 570, all sdd's, 16GB ram.
  • KamamuraKamamura Join Date: 2013-03-06 Member: 183736Members, Reinforced - Gold Posts: 668 Fully active user
    I did not have it, now I have it.
    Each day, hundreds of enthusiastic new players rush to join the ranks of the TSF to protect the universe, our beloved and the values of our society from the alien menace.

    Glory to the TSF! Glory to Arstotzka ! Glory to the mods!
  • KamamuraKamamura Join Date: 2013-03-06 Member: 183736Members, Reinforced - Gold Posts: 668 Fully active user
    Neoken wrote: »
    Enabling Vsync/triple buffering also seems to make the game feel a lot smoother for me, although it doesn't help inputdelay.

    It does, and I used it before, but I have found out it introduces even more input lag, so I have disabled it.
    Each day, hundreds of enthusiastic new players rush to join the ranks of the TSF to protect the universe, our beloved and the values of our society from the alien menace.

    Glory to the TSF! Glory to Arstotzka ! Glory to the mods!
  • Ghosthree3Ghosthree3 Join Date: 2010-02-13 Member: 70557Members, Reinforced - Supporter Posts: 3,416 Fully active user
    phoenixbbs wrote: »
    The input lag and microstuttering is apparently caused - at least in part - by using aero in windows - windows doesn't allow the game to automatically use the resources properly, even if it's full screen. The workaround is to find the executable and "disable desktop composition" in it's file properties here;

    C:\Program Files (x86)\Steam\steamapps\common\natural selection 2\NS2.exe

    Thanks to Samusdroid (Orphan Black) for picking up on this ! :-)

    76561197996992409.png
  • splitsplitsplitsplitsplitsplit Join Date: 2013-07-24 Member: 186370Members Posts: 3
    Maybe this is the problem? He says NS2 is not really running true Fullscreen:
    http://forums.unknownworlds.com/discussion/comment/2144889/#Comment_2144889

    That solved most of the problem for me. Full props to Orphan Black.
  • KamamuraKamamura Join Date: 2013-03-06 Member: 183736Members, Reinforced - Gold Posts: 668 Fully active user
    Well, I have found out that the culprit was the PhysX support option I turned on out of sheer curiosity. Now it's fine again.
    Each day, hundreds of enthusiastic new players rush to join the ranks of the TSF to protect the universe, our beloved and the values of our society from the alien menace.

    Glory to the TSF! Glory to Arstotzka ! Glory to the mods!
  • SamusDroidSamusDroid Colorado Join Date: 2013-05-13 Member: 185219Members, Forum Moderators, NS2 Playtester, Squad Five Gold, Subnautica Playtester, Community Dev Team, Pistachionauts Posts: 2,145 mod
    Turn desktop composition off in the exe's properties.
    My mods --- Watermod collaboration with Feha
    For some reason, the instant you ask players to behave differently to be successful, they associate that with bad mapping. - KungFuDiscoMonkey
    Z5UIr2s.png
  • EucomolhamasEucomolhamas Join Date: 2013-03-10 Member: 183841Members, Reinforced - Shadow Posts: 120 Advanced user
    Phew! Gotta say I got a little worried when I went in game and pretty much couldn't do a thing.

    Gonna try out the fixes tomorrow and hope for the best :P
  • DC_DarklingDC_Darkling Join Date: 2003-07-10 Member: 18068Members, Constellation, Squad Five Blue, Squad Five Silver Posts: 4,345 Advanced user
    PhysX support on GPUs is for nvidia only.
    Do not enable it unless you have a nvidia card.

    If you dont have it, it will run on the CPU.
  • ObraxisObraxis Subnautica Animator, NS2 Person Join Date: 2004-07-24 Member: 30071Super Administrators, Forum Admins, NS1 Playtester, Forum Moderators, NS2 Developer, Constellation, NS2 Playtester, Squad Five Silver, WC 2013 - Supporter, Subnautica Developer, Pistachionauts Posts: 2,907 admin
    edited September 2013
    Update:

    Create a new NS2 Shortcut.

    Right click on it, hit properties.

    Apply the following settings:

    noaero.JPG

    Run NS2 from this new shortcut. See if your FPS/Input Lag has improved.
  • ResRes Join Date: 2003-08-27 Member: 20245Members Posts: 626
    I did the mouse accel on/off and raw input off/on and also did the disable desktop composition.

    My mouse input lag is all but gone now.
  • ScaryGuyScaryGuy Join Date: 2013-09-01 Member: 187496Members, Reinforced - Shadow Posts: 4
    Obraxis wrote: »
    Update:

    Create a new NS2 Shortcut.

    Right click on it, hit properties.

    Apply the following settings:

    noaero.JPG

    Run NS2 from this new shortcut. See if your FPS/Input Lag has improved.

    Seems to have helped the mouse lag. AMD Crossfire is still broken, and the one video card that is working is running about 20 degrees C lower than before. Game is unplayable still.
  • Ghosthree3Ghosthree3 Join Date: 2010-02-13 Member: 70557Members, Reinforced - Supporter Posts: 3,416 Fully active user
    @Obraxis, the aero fix seems to have worked for at least one person I know with the problem.
    76561197996992409.png
  • MouseMouse The Lighter Side of Pessimism Join Date: 2002-03-02 Member: 263Members, NS1 Playtester, Forum Moderators, Squad Five Blue, Reinforced - Shadow, WC 2013 - Shadow Posts: 3,425 mod
    That fixed it :D

    (it also works for most of the rendering problems I've been having with the editor)
    -/AUS/- PS_Mouse
  • ObraxisObraxis Subnautica Animator, NS2 Person Join Date: 2004-07-24 Member: 30071Super Administrators, Forum Admins, NS1 Playtester, Forum Moderators, NS2 Developer, Constellation, NS2 Playtester, Squad Five Silver, WC 2013 - Supporter, Subnautica Developer, Pistachionauts Posts: 2,907 admin
    Yeah it's not the most elegant solution, but the current theory is that SDL is fighting Windows Aero for resources, so if you disable Aero NS2 get's priority again.

    Max and Dushan are on the case :)
  • EucomolhamasEucomolhamas Join Date: 2013-03-10 Member: 183841Members, Reinforced - Shadow Posts: 120 Advanced user
    That shortcut thingy fixed the stuttering (except I did it for the ns2.exe itself) but I couldn't fix the mouse acceleration issue with the suggestion posted here, any other ideas?
  • Ghosthree3Ghosthree3 Join Date: 2010-02-13 Member: 70557Members, Reinforced - Supporter Posts: 3,416 Fully active user
    You did the on/off switch listed in OP? That + no aero should work.
    76561197996992409.png
  • EucomolhamasEucomolhamas Join Date: 2013-03-10 Member: 183841Members, Reinforced - Shadow Posts: 120 Advanced user
    but I couldn't fix the mouse acceleration issue with the suggestion posted here

    @Ghosthree3 Yeah, I meant the on/off way with that. Tried it a couple of times with no effect. :(

  • HeavenfallHeavenfall Join Date: 2010-08-14 Member: 73620Members Posts: 30
    I tried the disabling Aero and it greatly reduced input delay, it is barely noticeable now for me. Massive FPS drops in combat remain very bad however.
    All to dust
  • -WildCat--WildCat- Cape Town, South Africa Join Date: 2008-07-19 Member: 64664Members, Reinforced - Shadow Posts: 131 Fully active user
    Obraxis wrote: »
    Turn on mouse accel, disable raw input
    Then
    Turn off mouse accel, turn on raw input

    This had no perceptible effect on input latency for me.

    I've got a Geforce GTX 690 and, when I run the game with multi-GPU enabled, I find that input latency is barely perceptible. If my frame rate is over 120 FPS, it seems pretty responsive. I feel like it might be marginally higher than other games but still acceptable.

    If I disable multi-GPU, my frame rate can drop as low as 55 FPS in certain areas of Biodome on an empty server. In these cases, I can definitely feel input latency. If I tap my mouse (in order to create a sudden jerky movement) and watch the screen out the corner of my eye, I can see the small delay. Even at the average 70 - 80 FPS, it still doesn't feel great.

    Obraxis wrote: »
    Update:

    Create a new NS2 Shortcut.

    Right click on it, hit properties.

    Apply the following settings:

    noaero.JPG

    Run NS2 from this new shortcut. See if your FPS/Input Lag has improved.

    This also had no perceptible impact on input latency. However, I was surprised to note that it prevented a strange frame rate anomaly that I described in my thread here:

    Build 254 / Biodome Technical Issues
    wildcat-spray-sig-red-75_zpsaa169b67.png
«1
This discussion has been closed.