Mic issue

HellianHellian Join Date: 2012-05-06 Member: 151632Members Posts: 5
Hey guys, so I'm having an issue with my Steel Series 2 V5 headphones, the mic doesn't seem to be broadcasting in natural selection (I've used it in other steam games) and it works perfectly on skype / mumble. I've tried setting the in game push to talk button to the same one as the one on steam & I've tried the auto broadcast in steam option but nothing seems to make people hear me in game, I've no idea wtf to do since this ist he first time I've had a problem where a mic isn't picked up by just a single program on my computer.


  • GsemiaGsemia Join Date: 2011-01-28 Member: 79297Members Posts: 17
    Hi there

    The utilities you mentioned support configuring the microphone (i think all of them) wheras Ns does not.. I think at least. NS uses the default microphone from Windows. It is possible to not have it set as default microphone, if you have multiple microphones on your computer.

    Do you use the Steel Series USB Sound card to plugin the headset to your computer ? in that case you would have 2 microphones. 1 from your mainboard and 1 from the usb sound card.

    In any case you can do the following: go to start -> Control panel -> Hardware and sound -> Sound -> switch to Recording tab.

    In this tab you should see your microphone and it should have action on the right side if you speak into it.

    If you have multiple microphones, make sure that the one which shows action is set to default.

    If that does not help, you are probably using a 3rd party sound driver which is interfering here. Check for a utility like realtek ac'97 audio and try to do the same as the windows utility would have done: Verify that there is input on the microphone and set the default microphone to the correct microphone.
  • ObraxisObraxis Subnautica Animator, NS2 Person Join Date: 2004-07-24 Member: 30071Super Administrators, Forum Admins, NS1 Playtester, Forum Moderators, NS2 Developer, Constellation, NS2 Playtester, Squad Five Silver, WC 2013 - Supporter, Subnautica Developer, Pistachionauts Posts: 2,835 admin
    Make sure the Mic is set to default in your 'Recording Devices' before launching NS2.

    Like this:


    Hope that helps.
  • HellianHellian Join Date: 2012-05-06 Member: 151632Members Posts: 5
    Thanks guys this was the issue which I find strange because I've never used a different jack for my mic or any thing, but thanks a bunch =)
Sign In or Register to comment.