Host_error

murphyt4murphyt4 Join Date: 2003-12-12 Member: 24297Posts: 130Members, Constellation
Hekp with this error
I am running Win XP server, and when I try to start sever on HLDS for NS, I get this error host_error:
couldnt get DLL API from \nsp\addons/metamod/dlls/metamod.dll!

p.s. I have the NS metamod.dll

Comments

  • JHunzJHunz Join Date: 2002-11-15 Member: 8815Posts: 331Members, Constellation
    Your path is messed up. I don't think you can have both forwards and backwards slashes in it.
    user posted image for life user posted image
    "We have enough youth, how about a fountain of smart?"
    For great players and great servers, Lunixmonster!
  • DashelDashel Join Date: 2003-03-24 Member: 14847Posts: 71Members
    Check your liblist.gam file in the NSP folder. It should show:

    gamedll "addons\metamod\dlls\metamod.dll"
    WinXP | XP2800 | 1GB XMS | 9800XT | nForce2
    GTW Game Hosting
  • murphyt4murphyt4 Join Date: 2003-12-12 Member: 24297Posts: 130Members, Constellation
    Hmm, My slashes were the other way in my dedicated server/nsp. I did that but now the error just says
    couldnt get DLL API from \nsp\addons\metamod\dlls\metamod.dll!

    any help?
  • DashelDashel Join Date: 2003-03-24 Member: 14847Posts: 71Members
    What have you edited so far? Just the liblist.gam? Have you verified the target path and try recopying the metamod.dll to that folder?

    Does your liblist entry look like mine?
    WinXP | XP2800 | 1GB XMS | 9800XT | nForce2
    GTW Game Hosting
  • murphyt4murphyt4 Join Date: 2003-12-12 Member: 24297Posts: 130Members, Constellation
    It is acting rather oddly now. HLDS loads fine, but when I click start server, it says loading, then dissapears and nothing happens. confused.gif



    asrifle.gif asrifle.gif
  • DashelDashel Join Date: 2003-03-24 Member: 14847Posts: 71Members
    You are using a modified shortcut to launch the server yes? It sounds like you are just trying to run steam...
    WinXP | XP2800 | 1GB XMS | 9800XT | nForce2
    GTW Game Hosting
  • murphyt4murphyt4 Join Date: 2003-12-12 Member: 24297Posts: 130Members, Constellation
    ?? I am just clicking on the HLDS button in games window.
  • murphyt4murphyt4 Join Date: 2003-12-12 Member: 24297Posts: 130Members, Constellation
    any help?
  • DashelDashel Join Date: 2003-03-24 Member: 14847Posts: 71Members
    Try lauching the server via a shortcut to get a better idea of where it is dying.

    ie:
    c:\SteamDir\hlds.exe -console -game nsp +maxplayers 20 +map ns_eclipse
    WinXP | XP2800 | 1GB XMS | 9800XT | nForce2
    GTW Game Hosting
  • murphyt4murphyt4 Join Date: 2003-12-12 Member: 24297Posts: 130Members, Constellation
    I did that but its still the same. If you dont know, my prob is that i click on HLDS, then it says preparing to play DS. Then i fill in the info and click Start Server. It says starting server... then it dissapears and does nothing.
  • DashelDashel Join Date: 2003-03-24 Member: 14847Posts: 71Members
    edited May 2004
    If you are 'filling things in' then you are not lauching from the shortcut properly. Your first step is to stop launching the server from inside steam itself. Once you have done that then diagnosing other errors becomes much easier. You should also temporality disable any meta or amx mod plugins. If your server has remote access PM me and I'll take a look at it.
    Post edited by Unknown User on
    WinXP | XP2800 | 1GB XMS | 9800XT | nForce2
    GTW Game Hosting
Sign In or Register to comment.